ES terminated without any error message

Hi, I am using version 7.13.2. I am setting up ES on remote server. ES worked for me last week, however, today when I tried to start it, it won't open anymore. It always shows Terminated or stop right after it shows JVM arguments in the terminal.

warning: usage of JAVA_HOME is deprecated, use ES_JAVA_HOME
warning: usage of JAVA_HOME is deprecated, use ES_JAVA_HOME
[2021-07-05T14:35:31,638][INFO ][o.e.n.Node               ] [node-1] version[7.13.2], pid[145977], build[default/tar/4d960a0733be83dd2543ca018aa4ddc42e956800/2021-06-10T21:01:55.251515791Z], OS[Linux/4.4.0-116-generic/amd64], JVM[AdoptOpenJDK/OpenJDK 64-Bit Server VM/16/16+36]
[2021-07-05T14:35:31,644][INFO ][o.e.n.Node               ] [node-1] JVM home [/home/liuc/elasticsearch/elasticsearch-7.13.2/jdk], using bundled JDK [true]
[2021-07-05T14:35:31,645][INFO ][o.e.n.Node               ] [node-1] JVM arguments [-Xshare:auto, -Des.networkaddress.cache.ttl=60, -Des.networkaddress.cache.negative.ttl=10, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -XX:+ShowCodeDetailsInExceptionMessages, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dio.netty.allocator.numDirectArenas=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Djava.locale.providers=SPI,COMPAT, --add-opens=java.base/, -XX:+UseG1GC, -XX:MaxGCPauseMillis=50, -XX:+UseG1GC,, -XX:+HeapDumpOnOutOfMemoryError, -XX:HeapDumpPath=data, -XX:ErrorFile=logs/hs_err_pid%p.log, -Xlog:gc*,gc+age=trace,safepoint:file=logs/gc.log:utctime,pid,tags:filecount=32,filesize=64m, -Xms31744m, -Xmx31744m, -XX:MaxDirectMemorySize=16642998272, -XX:InitiatingHeapOccupancyPercent=30, -XX:G1ReservePercent=25, -Des.path.home=/home/liuc/elasticsearch/elasticsearch-7.13.2, -Des.path.conf=/home/liuc/elasticsearch/elasticsearch-7.13.2/config, -Des.distribution.flavor=default, -Des.distribution.type=tar, -Des.bundled_jdk=true]

I have tried several ways. First, I added "-Xms512m -Xmx512m" in jvm.options, which didn't work. I also tried to reinstall ES again, which didn't work either.

Compared to my successful trial last week, today's ES search log is giving me one more JVM argument: -XX:G1HeapRegionSize=4m. I am not sure if this is causing the problem.

Could anyone help me with my issue? I'd really appreciate your help.

Welcome to our community! :smiley:

Please don't post pictures of text or code. They are difficult to read, impossible to search and replicate (if it's code), and some people may not be even able to see them :slight_smile:

Are there any other files in your elasticsearch logs directory?

The information you've given so far suggests that the Operating System is killing off the Elasticsearch process, but we might be able to get more details if there are other files to look at.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.