ES V2.x version on Ubuntu 16.04


(Nikhil R) #1

Does anyone here have a working cluster of ES v2.3.x version on Ubuntu 16.04. From the support metrics ES v2.x wont be supported on 16.04, however it would take us time to migrate to 5.x versions of ES


(Daniel Mitterdorfer) #2

Hi @Nikhil_R,

the support matrix shows the platform and software configurations that are "eligible for support under our subscription offerings.". This means that if you have a commercial support contract and you are filing a ticket with support and are on an unsupported platform we do not commit that we can help you.

Basically, ES 2.3.x should work fine on Ubuntu 16.04 but as we do not run any regular tests on this platform, we treat it as "not supported". I hope that helps you make a better decision.

Daniel


(Nikhil R) #3

Thanks @danielmitterdorfer
I read we need a full cluster restart. Can i get some insights to avoid such an upgrade?
We cannot have much downtime for the migration


(Daniel Mitterdorfer) #4

Hi @Nikhil_R,

peg my pardon but how is this question to your previous one? Can you please open a topic per question? (and also mark this one as resolved?)

Daniel


(Nikhil R) #5

Sure


(Nikhil R) #6

As per the OS recommendations as on October 25, i remember seeing 2.3.x being supported for Ubuntu 16.04.


(Daniel Mitterdorfer) #7

Hi @Nikhil_R,

If you mean by that, that the support matrix ever showed that, then I have to disappoint you. I just went through the revision history of the support matrix and the only supported version of Elasticsearch on Ubuntu 16.04 to this day is Elasticsearch 5.

Daniel


(Daniel Mitterdorfer) #8