Exception in thread "main" elasticsearchexception[failed to initialize a trustmanagerfactory]; nested: nosuchfileexception[/etc/elasticsearch/certs/elastic-certificates.p12]


(tabitha) #1

I am getting this message when I run the following command in the directory /usr/share/elasticsearch

bin/x-pack/setup-passwords interactive

Copy the applicable .p12 file into a directory within the Elasticsearch configuration directory on each node (the instructions after creating the certificate)

I am not understanding where else I am to copy the newly created certificate to. I tried to copy it to the following directory

/etc/elasticsearch/certs

however this file does not exist


(Tim Vernum) #2

Then you need to create the directory.
Elasticsearch just requires that the file is put somewhere within your config directory, and then you refer to that pathname in your elasticsearch.yml you can put it in a "certs/" directory, or a "tls/" directory, or directly in the /etc/elasticsearch directory if you want to, it's up to you.


(tabitha) #3

Thank you . Actually I did just that.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.