Facet term integer count overflow

Hi
We got a facet term integer overflow problem.
We have around 6 billon documents. when i'm faceting, the result count
value is overflowed like bellow.

--
afacet: {
_type: terms
missing: 0
total: 6679185342
other: 8589934592
terms: [
{
term: CISCO_55
count: -1910749250
}
]
}

https://groups.google.com/forum/?fromgroups#!topic/elasticsearch/VFpxNIVkfTQ
I saw this article. but i'm not sure the issue have fixed currently.

Is there something missing?

Thanks

Lee

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

To me, it looks like the issue is still there. The aggregater only accepts
ints as values with no overflow protection.

https://github.com/elasticsearch/elasticsearch/blob/master/src/main/java/org/elasticsearch/search/facet/terms/strings/InternalStringTermsFacet.java#L179

--
Ivan

On Thu, Jun 13, 2013 at 5:43 AM, 이해균 merlinet@gmail.com wrote:

Hi
We got a facet term integer overflow problem.
We have around 6 billon documents. when i'm faceting, the result count
value is overflowed like bellow.

--
afacet: {
_type: terms
missing: 0
total: 6679185342
other: 8589934592
terms: [
{
term: CISCO_55
count: -1910749250
}
]
}

https://groups.google.com/forum/?fromgroups#!topic/elasticsearch/VFpxNIVkfTQ
I saw this article. but i'm not sure the issue have fixed currently.

Is there something missing?

Thanks

Lee

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.