Failed stopping 'elasticsearch-service-x64' service

I'm getting this error every time I try to start and stop the elastic
search windows service.

Takes a couple of minutes then fails. I can kill the task in task manager
and then restart but cannot get it to stop on its own.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9385bbd6-914d-438c-a12f-cf90f992e278%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

By own it's own I mean service stop or using services.msc and clicking
restart on the service. Both attempts get the same error.

On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:

I'm getting this error every time I try to start and stop the elastic
search windows service.

Takes a couple of minutes then fails. I can kill the task in task manager
and then restart but cannot get it to stop on its own.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Do you see anything in the logs? Can you try removing and reinstalling the service? What's your OS/configuration?

On 1/2/15 10:32 PM, Garrett Johnson wrote:

By own it's own I mean service stop or using services.msc and clicking restart on the service. Both attempts get the
same error.

On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:

I'm getting this error every time I try to start and stop the elastic search windows service.

Takes a couple of minutes then fails.  I can kill the task in task manager and then restart but cannot get it to
stop on its own.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/54A81476.4020909%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

Log entries:
[2015-01-04 18:13:56,185][INFO ][node ] [Bucky III]
stopping ...
[2015-01-04 18:13:56,202][INFO ][river.jdbc.JDBCRiver ] river closed
[jdbc/users]
[2015-01-04 18:13:56,203][INFO ][river.jdbc.JDBCRiver ] river closed
[jdbc/product2]
[2015-01-04 18:13:56,342][INFO ][node ] [Bucky III]
stopped
[2015-01-04 18:13:56,342][INFO ][node ] [Bucky III]
closing ...
[2015-01-04 18:13:56,355][INFO ][node ] [Bucky III]
closed

Windows Server 2008R2

ElasticSearch 1.4.2
Plugins ElasticSearch Head, jdbc river 1.4.0.6

Microsoft jdbc driver.

Thanks,

Garrett

On Saturday, January 3, 2015 10:10:42 AM UTC-6, Costin Leau wrote:

Do you see anything in the logs? Can you try removing and reinstalling the
service? What's your OS/configuration?

On 1/2/15 10:32 PM, Garrett Johnson wrote:

By own it's own I mean service stop or using services.msc and clicking
restart on the service. Both attempts get the
same error.

On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:

I'm getting this error every time I try to start and stop the 

elastic search windows service.

Takes a couple of minutes then fails.  I can kill the task in task 

manager and then restart but cannot get it to

stop on its own. 

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to
elasticsearc...@googlegroups.com <javascript:> <mailto:
elasticsearch+unsubscribe@googlegroups.com <javascript:>>.
To view this discussion on the web visit

https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com

<
https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=email&utm_source=footer>.

For more options, visit https://groups.google.com/d/optout.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Does it also happen when you uninstall the JDBC river?

Also, I'd highly recommend using Linux servers for Elasticsearch instances
and not Windows ones

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, Jan 5, 2015 at 2:25 AM, Garrett Johnson garrettcjohnson@gmail.com
wrote:

Log entries:
[2015-01-04 18:13:56,185][INFO ][node ] [Bucky III]
stopping ...
[2015-01-04 18:13:56,202][INFO ][river.jdbc.JDBCRiver ] river closed
[jdbc/users]
[2015-01-04 18:13:56,203][INFO ][river.jdbc.JDBCRiver ] river closed
[jdbc/product2]
[2015-01-04 18:13:56,342][INFO ][node ] [Bucky III]
stopped
[2015-01-04 18:13:56,342][INFO ][node ] [Bucky III]
closing ...
[2015-01-04 18:13:56,355][INFO ][node ] [Bucky III]
closed

Windows Server 2008R2

ElasticSearch 1.4.2
Plugins ElasticSearch Head, jdbc river 1.4.0.6

Microsoft jdbc driver.

Thanks,

Garrett

On Saturday, January 3, 2015 10:10:42 AM UTC-6, Costin Leau wrote:

Do you see anything in the logs? Can you try removing and reinstalling
the service? What's your OS/configuration?

On 1/2/15 10:32 PM, Garrett Johnson wrote:

By own it's own I mean service stop or using services.msc and clicking
restart on the service. Both attempts get the
same error.

On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:

I'm getting this error every time I try to start and stop the

elastic search windows service.

Takes a couple of minutes then fails.  I can kill the task in task

manager and then restart but cannot get it to

stop on its own.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to
elasticsearc...@googlegroups.com <mailto:elasticsearch+
unsubscribe@googlegroups.com>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f4efa651-
9c60-4abb-b04a-47992f1c3e82%40googlegroups.com
<https://groups.google.com/d/msgid/elasticsearch/f4efa651-
9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=
email&utm_source=footer>.
For more options, visit https://groups.google.com/d/optout.

--
Costin

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zvr0bkpiNCwJpGWhPRV0POVn1eJQxcs%2Bb19MmtaiB%2BX_g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Can you turn on the logging of elasticsearch-service all the way to debug, start and stop the service and see whether
anything special appears in the logs?
You can do this by invoking >service manager and in the logging tab, changing the level from Info to Debug (see the
screenshot below):

The service wrapper log is elasticsearch-service-x64, in the same service as Elasticsearch log. Try and do some dry runs

  • simply starting and stopping the service (I also recommend removing the service and installing it fresh).
    You could also try removing the plugin and simply starting and stopping the fresh install of Elasticsearch to see
    whether it's a configuration problem or whether one of the plugins might affect the shutdown...

Cheers,

On 1/5/15 2:25 AM, Garrett Johnson wrote:

Log entries:
[2015-01-04 18:13:56,185][INFO ][node ] [Bucky III] stopping ...
[2015-01-04 18:13:56,202][INFO ][river.jdbc.JDBCRiver ] river closed [jdbc/users]
[2015-01-04 18:13:56,203][INFO ][river.jdbc.JDBCRiver ] river closed [jdbc/product2]
[2015-01-04 18:13:56,342][INFO ][node ] [Bucky III] stopped
[2015-01-04 18:13:56,342][INFO ][node ] [Bucky III] closing ...
[2015-01-04 18:13:56,355][INFO ][node ] [Bucky III] closed

Windows Server 2008R2

ElasticSearch 1.4.2
Plugins ElasticSearch Head, jdbc river 1.4.0.6

Microsoft jdbc driver.

Thanks,

Garrett

On Saturday, January 3, 2015 10:10:42 AM UTC-6, Costin Leau wrote:

Do you see anything in the logs? Can you try removing and reinstalling the service? What's your OS/configuration?

On 1/2/15 10:32 PM, Garrett Johnson wrote:
> By own it's own I mean service stop or using services.msc and clicking restart on the service.  Both attempts
get the
> same error.
>
> On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:
>
>     I'm getting this error every time I try to start and stop the elastic search windows service.
>
>     Takes a couple of minutes then fails.  I can kill the task in task manager and then restart but cannot get
it to
>     stop on its own.
>
> --
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to
> elasticsearc...@googlegroups.com <javascript:> <mailto:elasticsearch+unsubscribe@googlegroups.com <javascript:>>.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com
<https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com>
>
<https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=email&utm_source=footer
<https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=email&utm_source=footer>>.

> For more options, visit https://groups.google.com/d/optout <https://groups.google.com/d/optout>.

-- 
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/54AA4C17.8090103%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

It appears that after uninstall of the jdbc river it starts and stops just fine.

Sent from my iPhone

On Jan 5, 2015, at 1:36 AM, Itamar Syn-Hershko itamar@code972.com wrote:

Does it also happen when you uninstall the JDBC river?

Also, I'd highly recommend using Linux servers for Elasticsearch instances and not Windows ones

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, Jan 5, 2015 at 2:25 AM, Garrett Johnson garrettcjohnson@gmail.com wrote:
Log entries:
[2015-01-04 18:13:56,185][INFO ][node ] [Bucky III] stopping ...
[2015-01-04 18:13:56,202][INFO ][river.jdbc.JDBCRiver ] river closed [jdbc/users]
[2015-01-04 18:13:56,203][INFO ][river.jdbc.JDBCRiver ] river closed [jdbc/product2]
[2015-01-04 18:13:56,342][INFO ][node ] [Bucky III] stopped
[2015-01-04 18:13:56,342][INFO ][node ] [Bucky III] closing ...
[2015-01-04 18:13:56,355][INFO ][node ] [Bucky III] closed

Windows Server 2008R2

ElasticSearch 1.4.2
Plugins ElasticSearch Head, jdbc river 1.4.0.6

Microsoft jdbc driver.

Thanks,

Garrett

On Saturday, January 3, 2015 10:10:42 AM UTC-6, Costin Leau wrote:
Do you see anything in the logs? Can you try removing and reinstalling the service? What's your OS/configuration?

On 1/2/15 10:32 PM, Garrett Johnson wrote:

By own it's own I mean service stop or using services.msc and clicking restart on the service. Both attempts get the
same error.

On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:

I'm getting this error every time I try to start and stop the elastic search windows service. 

Takes a couple of minutes then fails.  I can kill the task in task manager and then restart but cannot get it to 
stop on its own. 

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
elasticsearc...@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/nzf4sUcf7n0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zvr0bkpiNCwJpGWhPRV0POVn1eJQxcs%2Bb19MmtaiB%2BX_g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/DD3CE8D9-D882-4557-B9F9-04DCB56B242C%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

It might be related then to the underlying JDBC driver. Try to change the driver or see if there are any parameters that
you could set.
Some drivers are buggy in that they prevent the JVM from shutting down correctly as they keep hanging on to the
underlying connections.
You could try using a connection pool in front, like c3p0 or BoneCP and see if it improves things.

On 1/6/15 6:35 AM, Garrett Johnson wrote:

It appears that after uninstall of the jdbc river it starts and stops just fine.

Sent from my iPhone

On Jan 5, 2015, at 1:36 AM, Itamar Syn-Hershko <itamar@code972.com mailto:itamar@code972.com> wrote:

Does it also happen when you uninstall the JDBC river?

Also, I'd highly recommend using Linux servers for Elasticsearch instances and not Windows ones

--

Itamar Syn-Hershko
http://code972.com http://code972.com/ | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, Jan 5, 2015 at 2:25 AM, Garrett Johnson <garrettcjohnson@gmail.com mailto:garrettcjohnson@gmail.com> wrote:

Log entries:
[2015-01-04 18:13:56,185][INFO ][node                     ] [Bucky III] stopping ...
[2015-01-04 18:13:56,202][INFO ][river.jdbc.JDBCRiver     ] river closed [jdbc/users]
[2015-01-04 18:13:56,203][INFO ][river.jdbc.JDBCRiver     ] river closed [jdbc/product2]
[2015-01-04 18:13:56,342][INFO ][node                     ] [Bucky III] stopped
[2015-01-04 18:13:56,342][INFO ][node                     ] [Bucky III] closing ...
[2015-01-04 18:13:56,355][INFO ][node                     ] [Bucky III] closed


Windows Server 2008R2

ElasticSearch 1.4.2
Plugins ElasticSearch Head, jdbc river 1.4.0.6

Microsoft jdbc driver.

Thanks,

Garrett


On Saturday, January 3, 2015 10:10:42 AM UTC-6, Costin Leau wrote:

    Do you see anything in the logs? Can you try removing and reinstalling the service? What's your OS/configuration?

    On 1/2/15 10:32 PM, Garrett Johnson wrote:
    > By own it's own I mean service stop or using services.msc and clicking restart on the service.  Both attempts get the
    > same error.
    >
    > On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:
    >
    >     I'm getting this error every time I try to start and stop the elastic search windows service.
    >
    >     Takes a couple of minutes then fails.  I can kill the task in task manager and then restart but cannot get it to
    >     stop on its own.
    >
    > --
    > You received this message because you are subscribed to the Google Groups "elasticsearch" group.
    > To unsubscribe from this group and stop receiving emails from it, send an email to
    >elasticsearc...@__googlegroups.com <mailto:elasticsearch+__unsubscribe@googlegroups.com>.
    > To view this discussion on the web visit
    >https://groups.google.com/d/__msgid/elasticsearch/f4efa651-__9c60-4abb-b04a-47992f1c3e82%__40googlegroups.com
    <https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com>
    > <https://groups.google.com/d/__msgid/elasticsearch/f4efa651-__9c60-4abb-b04a-47992f1c3e82%__40googlegroups.com?utm_medium=__email&utm_source=footer
    <https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=email&utm_source=footer>>.

    > For more options, visithttps://groups.google.com/d/__optout <https://groups.google.com/d/optout>.

    --
    Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
elasticsearch+unsubscribe@googlegroups.com <mailto:elasticsearch+unsubscribe@googlegroups.com>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com
<https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com?utm_medium=email&utm_source=footer>.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/nzf4sUcf7n0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com
mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zvr0bkpiNCwJpGWhPRV0POVn1eJQxcs%2Bb19MmtaiB%2BX_g%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zvr0bkpiNCwJpGWhPRV0POVn1eJQxcs%2Bb19MmtaiB%2BX_g%40mail.gmail.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/DD3CE8D9-D882-4557-B9F9-04DCB56B242C%40gmail.com
https://groups.google.com/d/msgid/elasticsearch/DD3CE8D9-D882-4557-B9F9-04DCB56B242C%40gmail.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/54ABC21E.1010107%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

I tried increasing the logging but it didn't give me anymore info.

I'm sure it is the jdbc driver as I have had to uninstall / reinstall
everything several times and without that jdbc river driver it's fine.

Since the search is working fine is there any issue with me having to kill
it to restart?

That said it is unwise for that to be the case in a production environment
regardless so can you give me and pointers to info about c3P0 and / or Bone
PC that directly relate to elasticsearch?

Thanks for your help

On Tuesday, January 6, 2015 5:08:37 AM UTC-6, Costin Leau wrote:

It might be related then to the underlying JDBC driver. Try to change the
driver or see if there are any parameters that
you could set.
Some drivers are buggy in that they prevent the JVM from shutting down
correctly as they keep hanging on to the
underlying connections.
You could try using a connection pool in front, like c3p0 or BoneCP and
see if it improves things.

Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/701e0c3e-d71c-487e-80e3-bc966c8d3f36%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

c3p0 / boneCP are basically connection pools around JDBC drivers. You can simply point your JDBC client (in this case
the jdbc river)
to c3p0 or bonecp which in turn, use the microsoft jdbc driver. Each connection pool has its own documentation on how to
configure it -
it's pretty similar to your jdbc configuration.

By the way, I forgot to mention the jTDS driver [1], an open-source implementation for SQL server and Sybase.
Try first with that and see whether it alleviates your issue if not, I would pick BoneCP first followed by C3P0.

You could also try to see whether the MS driver has any options (such as timeout) and enable tracing to figure out why
it's hanging [4]
[5]

Hope this helps,

[1] http://jtds.sourceforge.net/index.html
[2] http://jolbox.com/
[3] http://sourceforge.net/projects/c3p0/
[4] http://msdn.microsoft.com/en-us/library/ms378517.aspx
[5] http://msdn.microsoft.com/en-us/library/ms378522.aspx

On 1/7/15 5:43 AM, Garrett Johnson wrote:

I tried increasing the logging but it didn't give me anymore info.

I'm sure it is the jdbc driver as I have had to uninstall / reinstall everything several times and without that jdbc
river driver it's fine.

Since the search is working fine is there any issue with me having to kill it to restart?

That said it is unwise for that to be the case in a production environment regardless so can you give me and pointers to
info about c3P0 and / or Bone PC that directly relate to elasticsearch?

Thanks for your help

On Tuesday, January 6, 2015 5:08:37 AM UTC-6, Costin Leau wrote:

It might be related then to the underlying JDBC driver. Try to change the driver or see if there are any parameters
that
you could set.
Some drivers are buggy in that they prevent the JVM from shutting down correctly as they keep hanging on to the
underlying connections.
You could try using a connection pool in front, like c3p0 or BoneCP and see if it improves things.

Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/701e0c3e-d71c-487e-80e3-bc966c8d3f36%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/701e0c3e-d71c-487e-80e3-bc966c8d3f36%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/54AD0938.2000606%40gmail.com.
For more options, visit https://groups.google.com/d/optout.