Failed to complete action: snapshot. <class 'KeyError'>: 'indices'

I am stucked here, so I have configured curator to take snapshots on tha daily basis. but it fails with the error "Failed to complete action: snapshot. <class 'KeyError'>: 'indices'"
when I manually ran the curator command to take the snapshot it worked fine.
"curator --config /etc/curator/config.yaml /etc/curator/actions/cmx-daily.yaml"
curator, version 5.7.6

log---> 2024-06-09 04:00:02,179 INFO Preparing Action ID: 1, "snapshot"
2024-06-09 04:00:02,186 INFO Trying Action ID: 1, "snapshot": Create a daily snapshot of current month
2024-06-09 04:00:03,888 ERROR Failed to complete action: snapshot. <class 'KeyError'>: 'indices'

Mayank kumar

Curator 5.7.6 is very old and has not been updated in quite some time (nor will it be).

Curator versions 6, 7, and 8 are out, each designed to work with their respective versions of Elasticsearch. Please pick one of those and let me know if things are still not working as expected.

Hi thanks for the reply, do we have rpm for curator 7 ?

No. RPM distribution was discontinued due to compatibility issues.