Failed to get setting group for [threadpool.] setting prefix and setting [threadpool.bulk] because of a missing '.'


(marc.falzon) #1

Hello there

I noticed the following warning message in my nodes logs when starting:

[2015-04-30 12:40:13,265][INFO ][node ] [server]
started
[2015-04-30 12:40:32,154][WARN ][node.settings ] [server]
failed to refresh settings for
[org.elasticsearch.threadpool.ThreadPool$ApplySettings@1ca801ce]
org.elasticsearch.common.settings.SettingsException: Failed to get setting
group for [threadpool.] setting prefix and setting [threadpool.bulk]
because of a missing '.'
at
org.elasticsearch.common.settings.ImmutableSettings.getGroups(ImmutableSettings.java:527)
at
org.elasticsearch.common.settings.ImmutableSettings.getGroups(ImmutableSettings.java:505)
at
org.elasticsearch.threadpool.ThreadPool.updateSettings(ThreadPool.java:396)
at
org.elasticsearch.threadpool.ThreadPool$ApplySettings.onRefreshSettings(ThreadPool.java:682)
at
org.elasticsearch.node.settings.NodeSettingsService.clusterChanged(NodeSettingsService.java:84)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:428)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:134)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)

Here are the current cluster settings:

curl http://localhost:9200/_cluster/settings?pretty
{
"persistent" : {
"indices" : {
"store" : {
"throttle" : {
"max_bytes_per_sec" : "40mb"
}
}
},
"threadpool" : {
"bulk" : "250"
},
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all",
"balance" : {
"shard" : "0.9f"
},
"disable_allocation" : "false"
}
}
}
},
"transient" : {
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all"
}
}
}
}
}

Is there anything wrong with my settings? We tried to change the
threadpool.bulk setting months ago, but it doesn't seem to have been
taken into account (bulk queue still caped at default value). We currently
use version 1.2.3, and are in the process of upgrading to 1.5.x performing
rolling upgrades.

Cheers,

m.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/092de7fc-e290-4897-b7c6-f5985b0e8e7f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

How are you setting this?

On 30 April 2015 at 22:02, marc.falzon@happn.com wrote:

Hello there

I noticed the following warning message in my nodes logs when starting:

[2015-04-30 12:40:13,265][INFO ][node ] [server]
started
[2015-04-30 12:40:32,154][WARN ][node.settings ] [server]
failed to refresh settings for
[org.elasticsearch.threadpool.ThreadPool$ApplySettings@1ca801ce]
org.elasticsearch.common.settings.SettingsException: Failed to get setting
group for [threadpool.] setting prefix and setting [threadpool.bulk]
because of a missing '.'
at
org.elasticsearch.common.settings.ImmutableSettings.getGroups(ImmutableSettings.java:527)
at
org.elasticsearch.common.settings.ImmutableSettings.getGroups(ImmutableSettings.java:505)
at
org.elasticsearch.threadpool.ThreadPool.updateSettings(ThreadPool.java:396)
at
org.elasticsearch.threadpool.ThreadPool$ApplySettings.onRefreshSettings(ThreadPool.java:682)
at
org.elasticsearch.node.settings.NodeSettingsService.clusterChanged(NodeSettingsService.java:84)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:428)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:134)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)

Here are the current cluster settings:

curl http://localhost:9200/_cluster/settings?pretty
{
"persistent" : {
"indices" : {
"store" : {
"throttle" : {
"max_bytes_per_sec" : "40mb"
}
}
},
"threadpool" : {
"bulk" : "250"
},
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all",
"balance" : {
"shard" : "0.9f"
},
"disable_allocation" : "false"
}
}
}
},
"transient" : {
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all"
}
}
}
}
}

Is there anything wrong with my settings? We tried to change the
threadpool.bulk setting months ago, but it doesn't seem to have been
taken into account (bulk queue still caped at default value). We currently
use version 1.2.3, and are in the process of upgrading to 1.5.x performing
rolling upgrades.

Cheers,

m.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/092de7fc-e290-4897-b7c6-f5985b0e8e7f%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/092de7fc-e290-4897-b7c6-f5985b0e8e7f%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9SvQ5WmyX7jqUvL7FiR87JzBt8t2DLTiiXH_FEnnBKYg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(marc.falzon) #3

It was a few months ago so I don't exactly recall the command line we used,
but it must have been something like:

curl -X PUT -d '{
"persistent" : {
"threadpool.bulk": { "type": "fixed", "queue_size": 250 }
}
}' localhost:9200/_cluster/settings

m.

On Thursday, April 30, 2015 at 11:35:55 PM UTC+2, Mark Walkom wrote:

How are you setting this?

On 30 April 2015 at 22:02, <marc....@happn.com <javascript:>> wrote:

Hello there

I noticed the following warning message in my nodes logs when starting:

[2015-04-30 12:40:13,265][INFO ][node ]
[server] started
[2015-04-30 12:40:32,154][WARN ][node.settings ]
[server] failed to refresh settings for
[org.elasticsearch.threadpool.ThreadPool$ApplySettings@1ca801ce]
org.elasticsearch.common.settings.SettingsException: Failed to get
setting group for [threadpool.] setting prefix and setting
[threadpool.bulk] because of a missing '.'
at
org.elasticsearch.common.settings.ImmutableSettings.getGroups(ImmutableSettings.java:527)
at
org.elasticsearch.common.settings.ImmutableSettings.getGroups(ImmutableSettings.java:505)
at
org.elasticsearch.threadpool.ThreadPool.updateSettings(ThreadPool.java:396)
at
org.elasticsearch.threadpool.ThreadPool$ApplySettings.onRefreshSettings(ThreadPool.java:682)
at
org.elasticsearch.node.settings.NodeSettingsService.clusterChanged(NodeSettingsService.java:84)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:428)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:134)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)

Here are the current cluster settings:

curl http://localhost:9200/_cluster/settings?pretty
{
"persistent" : {
"indices" : {
"store" : {
"throttle" : {
"max_bytes_per_sec" : "40mb"
}
}
},
"threadpool" : {
"bulk" : "250"
},
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all",
"balance" : {
"shard" : "0.9f"
},
"disable_allocation" : "false"
}
}
}
},
"transient" : {
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all"
}
}
}
}
}

Is there anything wrong with my settings? We tried to change the
threadpool.bulk setting months ago, but it doesn't seem to have been
taken into account (bulk queue still caped at default value). We currently
use version 1.2.3, and are in the process of upgrading to 1.5.x performing
rolling upgrades.

Cheers,

m.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/092de7fc-e290-4897-b7c6-f5985b0e8e7f%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/092de7fc-e290-4897-b7c6-f5985b0e8e7f%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f8aac10d-51ad-4fbb-8d55-0cc56fd87978%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(marc.falzon) #4

Hello

Any idea regarding this issue, anyone?

Thank you,

m.

On Thursday, April 30, 2015 at 2:02:50 PM UTC+2, marc....@happn.fr wrote:

Hello there

I noticed the following warning message in my nodes logs when starting:

[2015-04-30 12:40:13,265][INFO ][node ] [server]
started
[2015-04-30 12:40:32,154][WARN ][node.settings ] [server]
failed to refresh settings for
[org.elasticsearch.threadpool.ThreadPool$ApplySettings@1ca801ce]
org.elasticsearch.common.settings.SettingsException: Failed to get setting
group for [threadpool.] setting prefix and setting [threadpool.bulk]
because of a missing '.'
at
org.elasticsearch.common.settings.ImmutableSettings.getGroups(ImmutableSettings.java:527)
at
org.elasticsearch.common.settings.ImmutableSettings.getGroups(ImmutableSettings.java:505)
at
org.elasticsearch.threadpool.ThreadPool.updateSettings(ThreadPool.java:396)
at
org.elasticsearch.threadpool.ThreadPool$ApplySettings.onRefreshSettings(ThreadPool.java:682)
at
org.elasticsearch.node.settings.NodeSettingsService.clusterChanged(NodeSettingsService.java:84)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:428)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:134)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)

Here are the current cluster settings:

curl http://localhost:9200/_cluster/settings?pretty
{
"persistent" : {
"indices" : {
"store" : {
"throttle" : {
"max_bytes_per_sec" : "40mb"
}
}
},
"threadpool" : {
"bulk" : "250"
},
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all",
"balance" : {
"shard" : "0.9f"
},
"disable_allocation" : "false"
}
}
}
},
"transient" : {
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all"
}
}
}
}
}

Is there anything wrong with my settings? We tried to change the
threadpool.bulk setting months ago, but it doesn't seem to have been
taken into account (bulk queue still caped at default value). We currently
use version 1.2.3, and are in the process of upgrading to 1.5.x performing
rolling upgrades.

Cheers,

m.

--
Please update your bookmarks! We moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/95f38d96-f918-493e-895c-87a50307343e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jason Wee) #5

for error, should really dig into the code and could probably give some
hint on why is that happening.

upgrading? perhaps you want to read this
http://www.elastic.co/guide/en/elasticsearch/reference/current/breaking-changes-1.4.html
as well. if you have use any of it and/or change the setting to those,
should really pay attention.

jason

On Wed, May 6, 2015 at 3:28 PM, marc.falzon@happn.com wrote:

Hello

Any idea regarding this issue, anyone?

Thank you,

m.

On Thursday, April 30, 2015 at 2:02:50 PM UTC+2, marc....@happn.fr wrote:

Hello there

I noticed the following warning message in my nodes logs when starting:

[2015-04-30 12:40:13,265][INFO ][node ]
[server] started
[2015-04-30 12:40:32,154][WARN ][node.settings ]
[server] failed to refresh settings for
[org.elasticsearch.threadpool.ThreadPool$ApplySettings@1ca801ce]
org.elasticsearch.common.settings.SettingsException: Failed to get
setting group for [threadpool.] setting prefix and setting
[threadpool.bulk] because of a missing '.'
at
org.elasticsearch.common.settings.ImmutableSettings.getGroups(ImmutableSettings.java:527)
at
org.elasticsearch.common.settings.ImmutableSettings.getGroups(ImmutableSettings.java:505)
at
org.elasticsearch.threadpool.ThreadPool.updateSettings(ThreadPool.java:396)
at
org.elasticsearch.threadpool.ThreadPool$ApplySettings.onRefreshSettings(ThreadPool.java:682)
at
org.elasticsearch.node.settings.NodeSettingsService.clusterChanged(NodeSettingsService.java:84)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:428)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:134)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)

Here are the current cluster settings:

curl http://localhost:9200/_cluster/settings?pretty
{
"persistent" : {
"indices" : {
"store" : {
"throttle" : {
"max_bytes_per_sec" : "40mb"
}
}
},
"threadpool" : {
"bulk" : "250"
},
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all",
"balance" : {
"shard" : "0.9f"
},
"disable_allocation" : "false"
}
}
}
},
"transient" : {
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all"
}
}
}
}
}

Is there anything wrong with my settings? We tried to change the
threadpool.bulk setting months ago, but it doesn't seem to have been
taken into account (bulk queue still caped at default value). We currently
use version 1.2.3, and are in the process of upgrading to 1.5.x performing
rolling upgrades.

Cheers,

m.

--
Please update your bookmarks! We moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/95f38d96-f918-493e-895c-87a50307343e%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/95f38d96-f918-493e-895c-87a50307343e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Please update your bookmarks! We moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHO4ity3h%2Bxcxc-cN8k8Qz9tXrMyYZX5UQNz8LmG4%3DKhTrkKug%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(marc.falzon) #6

Yes, we're very cautious about this upgrade and we're doing it in stages
(passing every last version of each 1.x branch: 1.2.4 => 1.3.9 => 1.4.5 =>
1.5.2).

m.

On Wednesday, May 6, 2015 at 1:56:01 PM UTC+2, Jason Wee wrote:

for error, should really dig into the code and could probably give some
hint on why is that happening.

upgrading? perhaps you want to read this
http://www.elastic.co/guide/en/elasticsearch/reference/current/breaking-changes-1.4.html
as well. if you have use any of it and/or change the setting to those,
should really pay attention.

jason

On Wed, May 6, 2015 at 3:28 PM, <marc....@happn.com <javascript:>> wrote:

Hello

Any idea regarding this issue, anyone?

Thank you,

m.

On Thursday, April 30, 2015 at 2:02:50 PM UTC+2, marc....@happn.fr wrote:

Hello there

I noticed the following warning message in my nodes logs when starting:

[2015-04-30 12:40:13,265][INFO ][node ]
[server] started
[2015-04-30 12:40:32,154][WARN ][node.settings ]
[server] failed to refresh settings for
[org.elasticsearch.threadpool.ThreadPool$ApplySettings@1ca801ce]
org.elasticsearch.common.settings.SettingsException: Failed to get
setting group for [threadpool.] setting prefix and setting
[threadpool.bulk] because of a missing '.'
at
org.elasticsearch.common.settings.ImmutableSettings.getGroups(ImmutableSettings.java:527)
at
org.elasticsearch.common.settings.ImmutableSettings.getGroups(ImmutableSettings.java:505)
at
org.elasticsearch.threadpool.ThreadPool.updateSettings(ThreadPool.java:396)
at
org.elasticsearch.threadpool.ThreadPool$ApplySettings.onRefreshSettings(ThreadPool.java:682)
at
org.elasticsearch.node.settings.NodeSettingsService.clusterChanged(NodeSettingsService.java:84)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:428)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:134)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)

Here are the current cluster settings:

curl http://localhost:9200/_cluster/settings?pretty
{
"persistent" : {
"indices" : {
"store" : {
"throttle" : {
"max_bytes_per_sec" : "40mb"
}
}
},
"threadpool" : {
"bulk" : "250"
},
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all",
"balance" : {
"shard" : "0.9f"
},
"disable_allocation" : "false"
}
}
}
},
"transient" : {
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all"
}
}
}
}
}

Is there anything wrong with my settings? We tried to change the
threadpool.bulk setting months ago, but it doesn't seem to have been
taken into account (bulk queue still caped at default value). We currently
use version 1.2.3, and are in the process of upgrading to 1.5.x performing
rolling upgrades.

Cheers,

m.

--
Please update your bookmarks! We moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/95f38d96-f918-493e-895c-87a50307343e%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/95f38d96-f918-493e-895c-87a50307343e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Please update your bookmarks! We moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/daf6c90f-95f5-4484-aa75-6b22934bb839%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #7