Updating threadpool settings in ES

Hello Everyone
I would like to get an advice about ES river and queue capacity increasing

I'm getting such an error:

[_river][1]: failed to execute [get [_river][database_name][_meta]: routing
[null]]
org.elasticsearch.common.util.concurrent.EsRejectedExecutionException:
rejected execution (queue capacity 1000) on
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction$1@31beb3a4

Looking for that issue solution I came to
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-threadpool.html

And here is shown an example:
threadpool:
index:
type:cached

How to run it properly against cluster?

I tried the following command:
curl -XPUT localhost:9200/_cluster/settings -d
'{"threadpool.index":{"type": "cached"}}'
and
curl -XPUT localhost:9200/_cluster/settings -d
'{"threadpool":{"index":{"type": "cached"}}}'
as per
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/cluster-update-settings.html

but it returned an error:
{"error":"ActionRequestValidationException[Validation Failed: 1: no
settings to update;]","status":400}

Please guide me how to apply those settings properly and how to specify it
in config file, as threadpool.bulk.queue_size: 50000 did work as well.

Thank you in advance!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a9db613e-4a00-4841-8c5f-25300a1f601d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I read "database_name " - do you use JDBC river?

If so, please increase max_bulk_actions parameter in JDBC plugin 1.3.4.4 to
a large value, like 5000 or 10000.

Changing threadpool.bulk is wrong and is not a solution. Where did you find
this "solution"?

Jörg

On Sun, Nov 9, 2014 at 6:22 PM, Maxim Fedchyshyn sevmax@gmail.com wrote:

Hello Everyone
I would like to get an advice about ES river and queue capacity increasing

I'm getting such an error:

[_river][1]: failed to execute [get [_river][database_name][_meta]:
routing [null]]
org.elasticsearch.common.util.concurrent.EsRejectedExecutionException:
rejected execution (queue capacity 1000) on
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction$1@31beb3a4

Looking for that issue solution I came to
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-threadpool.html

And here is shown an example:
threadpool:
index:
type:cached

How to run it properly against cluster?

I tried the following command:
curl -XPUT localhost:9200/_cluster/settings -d
'{"threadpool.index":{"type": "cached"}}'
and
curl -XPUT localhost:9200/_cluster/settings -d
'{"threadpool":{"index":{"type": "cached"}}}'
as per
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/cluster-update-settings.html

but it returned an error:
{"error":"ActionRequestValidationException[Validation Failed: 1: no
settings to update;]","status":400}

Please guide me how to apply those settings properly and how to specify it
in config file, as threadpool.bulk.queue_size: 50000 did work as well.

Thank you in advance!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/a9db613e-4a00-4841-8c5f-25300a1f601d%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/a9db613e-4a00-4841-8c5f-25300a1f601d%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoEBN1C-PNYAOQR14aZ6Ay%3D%2BF8bLkjwfpWHNvWfR-ib8nA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.