Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin] ELASTICSEARCH

HEllo i have just installed x-pack on elasticsearch ,kibana, logstash and once i start elasticsearch i get this, any clues?

thanks in advance

Blockquote[2017-12-05T15:00:29,194][INFO ][o.e.n.Node ] [] initializing ...
[2017-12-05T15:00:29,337][INFO ][o.e.e.NodeEnvironment ] [DAg1kKg] using [1] data paths, mounts [[/home (/dev/sda8)]], net usable_space [391.6gb], net total_space [419.6gb], spins? [possibly], types [ext4]
[2017-12-05T15:00:29,337][INFO ][o.e.e.NodeEnvironment ] [DAg1kKg] heap size [1.9gb], compressed ordinary object pointers [true]
[2017-12-05T15:00:29,449][INFO ][o.e.n.Node ] node name [DAg1kKg] derived from node ID [DAg1kKgvTeSdN_15z1aL-w]; set [node.name] to override
[2017-12-05T15:00:29,449][INFO ][o.e.n.Node ] version[5.6.4], pid[4229], build[8bbedf5/2017-10-31T18:55:38.105Z], OS[Linux/4.12.0-kali1-amd64/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/1.8.0_144/25.144-b01]
[2017-12-05T15:00:29,449][INFO ][o.e.n.Node ] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -Djdk.io.permissionsUseCanonicalPath=true, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j.skipJansi=true, -XX:+HeapDumpOnOutOfMemoryError, -Des.path.home=/home/secis/Documents/ELK/elasticsearch-5.6.4]
[2017-12-05T15:00:30,625][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: ElasticsearchException[Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin]]; nested: InvocationTargetException; nested: IllegalArgumentException[the [action.auto_create_index] setting value [.security,.monitoring*,.watches,.triggered_watches,.watcher-history*,.ml*] is too restrictive. disable [action.auto_create_index] or set it to [.security,.security-6]];
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:123) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:70) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:134) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) ~[elasticsearch-5.6.4.jar:5.6.4]
Caused by: org.elasticsearch.ElasticsearchException: Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin]
at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:438) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:391) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:141) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.node.Node.(Node.java:313) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.node.Node.(Node.java:245) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:233) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:233) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:342) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:132) ~[elasticsearch-5.6.4.jar:5.6.4]
... 6 more
Caused by: java.lang.reflect.InvocationTargetException
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:?]
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:?]
at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0_144]
at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:427) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:391) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:141) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.node.Node.(Node.java:313) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.node.Node.(Node.java:245) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:233) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:233) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:342) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:132) ~[elasticsearch-5.6.4.jar:5.6.4]
... 6 more
Caused by: java.lang.IllegalArgumentException: the [action.auto_create_index] setting value [.security,.monitoring*,.watches,.triggered_watches,.watcher-history*,.ml*] is too restrictive. disable [action.auto_create_index] or set it to [.security,.security-6]
at org.elasticsearch.xpack.security.Security.validateAutoCreateIndex(Security.java:812) ~[?:?]
at org.elasticsearch.xpack.security.Security.(Security.java:252) ~[?:?]
at org.elasticsearch.xpack.XPackPlugin.(XPackPlugin.java:219) ~[?:?]
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:?]
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:?]
at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0_144]
at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:427) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:391) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:141) ~[elasticsearch-

The error is contained in the message, it was unable to start because it needs to be able to create a certain index (for the security index), see:

Specifically:

the [action.auto_create_index] setting value [.security,.monitoring*,.watches,.triggered_watches,.watcher-history*,.ml*] is too restrictive. disable [action.auto_create_index] or set it to [.security,.security-6]

You'll need to update the action.auto_create_index settingand restart ES.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.