Failed to setup multicast discovery on port [54328] ES can't connect to cluster


(Oğulcan Selcuk Akbulut) #1

[2014-02-19 20:40:58,668][INFO ][node ]
[elastic_inst2] {0.90.0.Beta1}[1368]: initializing ...
[2014-02-19 20:40:58,676][INFO ][plugins ]
[elastic_inst2] loaded [], sites []
[2014-02-19 20:41:01,402][INFO ][node ]
[elastic_inst2] {0.90.0.Beta1}[1368]: initialized
[2014-02-19 20:41:01,403][INFO ][node ]
[elastic_inst2] {0.90.0.Beta1}[1368]: starting ...
[2014-02-19 20:41:01,501][INFO ][transport ]
[elastic_inst2] bound_address {inet[/0:0:0:0:0:0:0:0:9301]},
publish_address {inet[/192.168.2.130:9301]}
[2014-02-19 20:41:01,521][WARN ][discovery.zen.ping.multicast]
[elastic_inst2] disabled, failed to setup multicast discovery on port
[54328], [/192.168.2.130]: Invalid argument
[2014-02-19 20:41:04,563][INFO ][cluster.service ]
[elastic_inst2] new_master
[elastic_inst2][VVoWrIc4QRuiSo9-0lhd1g][inet[/192.168.2.130:9301]], reason:
zen-disco-join (elected_as_master)
[2014-02-19 20:41:04,595][INFO ][discovery ]
[elastic_inst2] elasticsearch_dc1/VVoWrIc4QRuiSo9-0lhd1g
[2014-02-19 20:41:05,573][INFO ][http ]
[elastic_inst2] bound_address {inet[/0:0:0:0:0:0:0:0:9201]},
publish_address {inet[/192.168.2.130:9201]}
[2014-02-19 20:41:05,573][INFO ][node ]
[elastic_inst2] {0.90.0.Beta1}[1368]: started
[2014-02-19 20:41:05,576][INFO ][gateway ]
[elastic_inst2] recovered [0] indices into cluster_state

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/507affac-fe3f-4501-ad4d-6a8c4a5672fb%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #2

Hey,

first, you should really upgrade elasticsearch, this is quite an old beta
version.
Second, if you are using something like amazon ec2, multicast is disabled.
You might want to test with unicast in that case, see
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html#unicast

--Alex

On Wed, Feb 19, 2014 at 7:56 PM, Oğulcan Selcuk Akbulut gaplan@gmail.comwrote:

[2014-02-19 20:40:58,668][INFO ][node ]

[elastic_inst2] {0.90.0.Beta1}[1368]: initializing ...
[2014-02-19 20:40:58,676][INFO ][plugins ]
[elastic_inst2] loaded [], sites []
[2014-02-19 20:41:01,402][INFO ][node ]
[elastic_inst2] {0.90.0.Beta1}[1368]: initialized
[2014-02-19 20:41:01,403][INFO ][node ]
[elastic_inst2] {0.90.0.Beta1}[1368]: starting ...
[2014-02-19 20:41:01,501][INFO ][transport ]
[elastic_inst2] bound_address {inet[/0:0:0:0:0:0:0:0:9301]},
publish_address {inet[/192.168.2.130:9301]}
[2014-02-19 20:41:01,521][WARN ][discovery.zen.ping.multicast]
[elastic_inst2] disabled, failed to setup multicast discovery on port
[54328], [/192.168.2.130]: Invalid argument
[2014-02-19 20:41:04,563][INFO ][cluster.service ]
[elastic_inst2] new_master
[elastic_inst2][VVoWrIc4QRuiSo9-0lhd1g][inet[/192.168.2.130:9301]],
reason: zen-disco-join (elected_as_master)
[2014-02-19 20:41:04,595][INFO ][discovery ]
[elastic_inst2] elasticsearch_dc1/VVoWrIc4QRuiSo9-0lhd1g
[2014-02-19 20:41:05,573][INFO ][http ]
[elastic_inst2] bound_address {inet[/0:0:0:0:0:0:0:0:9201]},
publish_address {inet[/192.168.2.130:9201]}
[2014-02-19 20:41:05,573][INFO ][node ]
[elastic_inst2] {0.90.0.Beta1}[1368]: started
[2014-02-19 20:41:05,576][INFO ][gateway ]
[elastic_inst2] recovered [0] indices into cluster_state

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/507affac-fe3f-4501-ad4d-6a8c4a5672fb%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM8t%3DPTOV%3DGLGyPnvX-zbN910NmR_GW6FmVb%3DBy9ZOVMjA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3