Failed to start Logstash - S3 output plugin is not working

Hi. I'm using Logstash.

I recently upgraded Logstash to version 8.7.0, but it's not working. I'm getting an error message.

Failed to execute action {:action=>LogStash::PipelineAction::Create/pipeline_id:OSQUERY, :exception=>"Java::JavaLang::IllegalStateException", :message=>"Unable to configure plugins: (RuntimeError) \n\n\tyou might need to reinstall the gem which depends on the missing jar or in case there is Jars.lock then resolve the jars with `lock_jars` command\n\nno such file to load -- org/logstash/plugins/integration/aws/logstash-integration-aws/7.1.0/logstash-integration-aws-7.1.0.jar (LoadError)", :backtrace=>["<init>(", "org.logstash.execution.AbstractPipelineExt.initialize(", "org.logstash.execution.AbstractPipelineExt$INVOKER$i$$INVOKER$i$initialize.gen)", "org.jruby.internal.runtime.methods.JavaMethod$", "", "", "", "usr.share.logstash.logstash_minus_core.lib.logstash.java_pipeline.RUBY$method$initialize$0(/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:48)", "usr.share.logstash.logstash_minus_core.lib.logstash.pipeline_action.create.RUBY$method$execute$0(/usr/share/logstash/logstash-core/lib/logstash/pipeline_action/create.rb:50)", "usr.share.logstash.logstash_minus_core.lib.logstash.agent.RUBY$block$converge_state$2(/usr/share/logstash/logstash-core/lib/logstash/agent.rb:386)", "org.jruby.runtime.CompiledIRBlockBody.callDirect(", "", "", "", "", "", "java.base/"]}

Only pipelines that use the s3 output plugin are not working.

Previous Version: 8.5.3

What I tried to do to solve the problem:

  • Reinstall Java
  • Reinstall Gem
  • Reinstall Ruby
  • Reinstall Logstash

I did all of these but the problem still persisted.

My S3 Output Plugin Conf.

output {
    s3 {
        region                  => "My Region"
        bucket                  => "My Bucket"

        validate_credentials_on_root_bucket => true 
        temporary_directory     => "./_temp/s3/" 
        rotation_strategy       => "size_and_time"
        time_file               => 10 
        prefix                  => "ysp/"
        encoding                => "gzip"
        retry_count             => 3 
        retry_delay             => 3
        codec                   => json_lines
        enable_metric           => false

What should I do?

Same story here. Version 8.5.3 worked. But the lastest release 8.7.0 is giving me same error.

I think they will do a bug fix release soon.

Thank you for your response.

Since there are no other responses, I guess I have to wait.

If anyone has solved this problem, please provide an answer.

@WonhyeongCho Have you raised a bug report for this?

Did you open a bug report? Without it Elastic probably doesn't even know about this issue.

You need to open a bug report on the plugin repository

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.