Failure to execute ttl purge


(Raz Baluchi) #1

Our cluster has started to spit out error messages related to purge
failures. It also appears to have adversely impacted performance. The error
message is below, any ideas on where to look to fix this error?

[2014-08-04 13:37:22,949][WARN ][indices.ttl ] [prod2] failed
to execute ttl purge
java.lang.ClassCastException:
org.elasticsearch.index.mapper.core.StringFieldMapper cannot be cast to
org.elasticsearch.index.mapper.internal.TTLFieldMapper
at
org.elasticsearch.indices.ttl.IndicesTTLService$PurgerThread.getShardsToPurge(IndicesTTLService.java:180)
at
org.elasticsearch.indices.ttl.IndicesTTLService$PurgerThread.run(IndicesTTLService.java:139)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/89164f46-0efe-430c-a65f-6e5d070a1106%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Brian Yoder) #2

What version of Elasticsearch? Of Java?

How is TTL being used? For example, one extreme is to constantly add log
data and then delete old data. This case is, of course, best handled with
time-based indices and a tool such as curator to delete old data by index
and not by individual document via TTL.

I have run some test cases with TTL using Elasticsearch 1.3.0 and Java
7u60. I set a _ttl value of 5m and hammered Elasticsearch. After some time
passed and several million documents had been added, I shut down the test
and watched the TTL processing clean up. It took some time but it always
succeeded. It was rather nice to see that my TTL tests were self-cleaning:
I always ended up with an empty index after each run.

This discussion may also shed a bit of light:
http://elasticsearch-users.115913.n3.nabble.com/TTL-Load-Problems-td4024001.html

Brian

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8544b414-5017-465e-bdd2-665e0e52db7d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3