Low indices.ttl.interval is NOT working


(Pallavi Mishra) #1

I have set 'indices.ttl.interval' to 15 sec using following curl command:

curl -XPUT localhost:9200/_cluster/settings -d '{ "transient": {
"indices.ttl.interval": "15s" } }'

I have checked that the value is set properly by using the CURL command
too. However, it does NOT delete the documents from Elastic search after 15
sec .I have gone through various related links, however there is no
suggestion is working for me:

https://groups.google.com/forum/#!searchin/elasticsearch/indices.ttl.interval/elasticsearch/4-_lNiP8mps/wcKcmfWselYJ

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/cluster-update-settings.html

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-ttl-field.html

When I try with 20-25 sec, document clean up happens randomly. Having 15
sec is too high, ideally I expect it to work with 5 sec.

Queries:

  • What do you suggest to get rid off this issue?
  • What are possible causes of such failure?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0388ac73-3625-4f7f-8258-d6cdb53a0cba%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #2

Hey,

This should clarify things (the cleanup threads runs only once per minute
by default):
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-ttl-field.html#_note_on_documents_expiration

--Alex

On Mon, Mar 3, 2014 at 3:23 PM, Pallavi Mishra
pallavimishra018@gmail.comwrote:

I have set 'indices.ttl.interval' to 15 sec using following curl command:

curl -XPUT localhost:9200/_cluster/settings -d '{ "transient": {
"indices.ttl.interval": "15s" } }'

I have checked that the value is set properly by using the CURL command
too. However, it does NOT delete the documents from Elastic search after 15
sec .I have gone through various related links, however there is no
suggestion is working for me:

https://groups.google.com/forum/#!searchin/elasticsearch/indices.ttl.interval/elasticsearch/4-_lNiP8mps/wcKcmfWselYJ

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/cluster-update-settings.html

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-ttl-field.html

When I try with 20-25 sec, document clean up happens randomly. Having 15
sec is too high, ideally I expect it to work with 5 sec.

Queries:

  • What do you suggest to get rid off this issue?
  • What are possible causes of such failure?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/0388ac73-3625-4f7f-8258-d6cdb53a0cba%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM-eBumjs_Bsb_PVmOKGuCXO%3DJNUd2BsUw6SiwkAjzKMrA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Pallavi Mishra) #3

Hi Alex,
Thanks for response. But that is the default value and we can alter the
value.
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-ttl-field.html#_default
.
Do you have more information regarding this issue then please suggest.

On Monday, March 3, 2014 9:43:15 PM UTC+5:30, Alexander Reelsen wrote:

Hey,

This should clarify things (the cleanup threads runs only once per minute
by default):
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-ttl-field.html#_note_on_documents_expiration

--Alex

On Mon, Mar 3, 2014 at 3:23 PM, Pallavi Mishra <pallavim...@gmail.com<javascript:>

wrote:

I have set 'indices.ttl.interval' to 15 sec using following curl command:

curl -XPUT localhost:9200/_cluster/settings -d '{ "transient": {
"indices.ttl.interval": "15s" } }'

I have checked that the value is set properly by using the CURL command
too. However, it does NOT delete the documents from Elastic search after 15
sec .I have gone through various related links, however there is no
suggestion is working for me:

https://groups.google.com/forum/#!searchin/elasticsearch/indices.ttl.interval/elasticsearch/4-_lNiP8mps/wcKcmfWselYJ

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/cluster-update-settings.html

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-ttl-field.html

When I try with 20-25 sec, document clean up happens randomly. Having 15
sec is too high, ideally I expect it to work with 5 sec.

Queries:

  • What do you suggest to get rid off this issue?
  • What are possible causes of such failure?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/0388ac73-3625-4f7f-8258-d6cdb53a0cba%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/df6d433a-3e94-40cc-a2dd-cfd02bec7f09%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #4

Hey,

wow. I only read what I wanted to read and skipped the first paragraph.
sorry for that.

The clean up thread basically sleeps the specified interval, only when the
interval is updated and the old sleep interval has been finished, the new
settings are applied. This means you might need to wait an additional run
(thats what the second sleep is doing in the below example). From then on,
everything should work as expected.

curl -X DELETE localhost:9200/test
curl -X PUT localhost:9200/test
curl -X PUT localhost:9200/test/test/_mapping -d '{ "test" : { "_ttl" : {
"enabled" : true } } }'
curl -X PUT 'localhost:9200/test/test/1?ttl=30s' -d '{ "foo" : "bar" }'
curl -X GET localhost:9200/test/test/1
sleep 60
curl -X GET localhost:9200/test/test/1
curl -XPUT localhost:9200/_cluster/settings -d '{ "transient" : {
"indices.ttl.interval" : "15s" } }'
sleep 60
curl -X PUT 'localhost:9200/test/test/1?ttl=10s' -d '{ "foo" : "bar" }'
curl -X GET localhost:9200/test/test/1
sleep 15
curl -X GET localhost:9200/test/test/1

If the above does not for you/in your case, there might be a bug, and I
would like you to file an issue, with the exact steps for reproducing (like
above). Thanks

--Alex

On Tue, Mar 4, 2014 at 6:36 AM, Pallavi Mishra
pallavimishra018@gmail.comwrote:

Hi Alex,
Thanks for response. But that is the default value and we can alter the
value.
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-ttl-field.html#_default
.
Do you have more information regarding this issue then please suggest.

On Monday, March 3, 2014 9:43:15 PM UTC+5:30, Alexander Reelsen wrote:

Hey,

This should clarify things (the cleanup threads runs only once per minute
by default): http://www.elasticsearch.org/guide/en/elasticsearch/
reference/current/mapping-ttl-field.html#_note_on_documents_expiration

--Alex

On Mon, Mar 3, 2014 at 3:23 PM, Pallavi Mishra pallavim...@gmail.comwrote:

I have set 'indices.ttl.interval' to 15 sec using following curl command:

curl -XPUT localhost:9200/_cluster/settings -d '{ "transient": {
"indices.ttl.interval": "15s" } }'

I have checked that the value is set properly by using the CURL command
too. However, it does NOT delete the documents from Elastic search after 15
sec .I have gone through various related links, however there is no
suggestion is working for me:

When I try with 20-25 sec, document clean up happens randomly. Having 15
sec is too high, ideally I expect it to work with 5 sec.

Queries:

  • What do you suggest to get rid off this issue?
  • What are possible causes of such failure?

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/0388ac73-3625-4f7f-8258-d6cdb53a0cba%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/df6d433a-3e94-40cc-a2dd-cfd02bec7f09%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/df6d433a-3e94-40cc-a2dd-cfd02bec7f09%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM_JuOY2csW6aVTsQc_qfKxg%2B1c9a1zUHVfmPRtWwXNUZA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5