Field data loading is forbidden on Hostname


#1

There are two previous posts that were solved without really any solution being brought up in my opinion.

I've stood up the latest version of the ELK stack and my current issue resolves around the error in the topic. I'm importing Windows Event Viewer events into ElasticSearch. If I try to visualize one of the fields from the discovery tab, I get the following:

java.lang.IllegalStateException: Field data loading is forbidden on Hostname

Error: Request to Elasticsearch failed: {"error":{"root_cause":[{"type":"exception","reason":"java.lang.IllegalStateException: Field data loading is forbidden on Hostname"}],"type":"search_phase_execution_exception","reason":"all shards failed","phase":"query","grouped":true,"failed_shards":[{"shard":0,"index":"logstash-events-np-2015-12-09","node":"71r9cE4PT1SleUFfsBZbfQ","reason":{"type":"exception","reason":"java.lang.IllegalStateException: Field data loading is forbidden on Hostname","caused_by":{"type":"unchecked_execution_exception","reason":"java.lang.IllegalStateException: Field data loading is forbidden on Hostname","caused_by":{"type":"illegal_state_exception","reason":"Field data loading is forbidden on Hostname"}}}}]}}
at http://nwslkibanacp001.my.com/bundles/kibana.bundle.js:78760:39
at Function.Promise.try (http://nwslkibanacp001.my.com/bundles/commons.bundle.js:60967:23)
at http://nwslkibanacp001.my.com/bundles/commons.bundle.js:60936:31
at Array.map (native)
at Function.Promise.map (http://nwslkibanacp001.my.com/bundles/commons.bundle.js:60935:31)
at callResponseHandlers (http://nwslkibanacp001.my.com/bundles/kibana.bundle.js:78732:23)
at http://nwslkibanacp001.my.com/bundles/kibana.bundle.js:78239:17
at processQueue (http://nwslkibanacp001.my.com/bundles/commons.bundle.js:42339:29)
at http://nwslkibanacp001.my.com/bundles/commons.bundle.js:42355:28
at Scope.$eval (http://nwslkibanacp001.my.com/bundles/commons.bundle.js:43583:29)

Is there something that I need to do at the index level in order to load that field?


(Cybacolt) #2

same problem here on a brand new install. theres a related issue on github:

no responses yet unfortunately... i posted what fixed it for me on that github issue.


(system) #3