Field _source added to mapping automatically is shown in Discovery as empty

Hello,

I have a mapping which is "dynamic": false.

By POST first message, there was automatically added few fields which i didn't defined.
I understood that it is mandatory to have there:

  • _id | string
  • _index | string
  • _score | number
  • _type | string

But why it is adding also

  • _source | _source

and then complain in Discovery that

? _source
This field is present in your Elasticsearch mapping but not in the 0 documents shown in the doc table. You may still be able to visualize or search on it.

?

How can I remove the _source from Available fields list?

Hi

You could remove _source in our Stack Management / Advanced Settings Page , by editing metaFields.

Best,
Matthias

Thank you. I have found it. But is it save to remove the _source from the advance settings?
Wouldn't that impact existing data?

There is no data modified, it just determines what is being displayed, so yes, it's safe!
Best,
Matthias