Filebeat 5.3.3 import dashboard 404's


(Byron Nagi) #1

Hello,

I've been following the installation guides for installing filebeat 5.3. I got it running but I've been trying to import the dashboard to kibana and ran into what I think is a bug.

I pulled down the beat source code with:
go get github.com/elastic/beats

then checked out version 5.3 with:
git checkout 5.3

In the beats/libbeat/dashboards directory I ran
make

Everything up to this was fine but when I ran
./import_dashboards -beat filebeat

I got an error
Create temporary directory /tmp/tmp150029556 Downloading https://artifacts.elastic.co/downloads/beats/beats-dashboards/beats-dashboards-5.3.3.zip Unzip archive /tmp/tmp150029556 Error importing URL/file: Failed to unzip the archive: /tmp/tmp150029556/beats-dashboards-5.3.3.zip Exiting
I thought this might be an issue on my system (gentoo x86_64) but after looking into the url turns out
https://artifacts.elastic.co/downloads/beats/beats-dashboards/beats-dashboards-5.3.3.zip 404's. However 5.3.2 works -- looking at the github releases there is no 5.3.3 but I confirmed by running `beats/dev-tools/get_version that it returns 5.3.3 on the 5.3 branch. I'm not sure if the version should or shouldn't be 5.3.3 or 5.3.2 but if you follow the docs no one will be able to download the dashboards for 5.3.

This is rather confusing and annoying to figure out. Especially if you're not a person who likes to hunt around the source code for answers.


(ruflin) #2

The next tagged release for the 5.3 branch is 5.3.3. So the above is all fine except that obviously the downloads are not available before it is released.

If you want to check out and build a specific version, check out the specific tag.

What were you trying to do in the first place? Why did you build the dashboard script yourself? Was this do debug the potential bug? Can you share the error you got?


(Byron Nagi) #3

If it's expected than it's no issue -- The gentoo package doesn't make the import_dashboards script available so I was compiling it myself. I think I totally forgot to checkout the tag instead of the branch as you say. My mistake. Thanks for the quick response!


(ruflin) #4

Which package did you use? I was under the assumption if you use one of the official packages, the import_dashboard script should always be somewhere on your disk.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.