Filebeat cannot find /etc/filebeat/filebeat.yml on Windows server

I've been banging my head against this for a while now, and no matter what I do (installing from .zip, running from .exe release, or running from what go get brings me), I'm unable to even execute filebeat.exe because it cannot find the path to filebeat.yml. What's odd is that I'm looking at that very path to filebeat.yml.

I also can't seem to get the service to install from git bash or powershell, because godep is not recognized, despite the fact that I've installed it.

I have environment variables set for Go (which I've installed to C:\Go), it's added to my path and I'm able to run Go commands from both git bash and powershell.

Am I just missing something silly, or have I gone about this the entirely wrong way? I can provide any further config/output if it would be helpful

Use a prebuilt binary and use the -c option to change the path to the configuration file. Having /etc/filebeat/filebeat.yml as the default on Windows doesn't make sense but I don't know what would be a more sensible default.

I totally forgot to reply to this. It worked, thanks!

For anybody struggling to get it to install as a service, edit the install script to point to the executable and yml file without relying on $workdir. In mycase it was: C:\Filebeat\filebeat.exe -c C:\Filebeat\filebeat.yml

Hi ,

Is Filebeat works with Windows2008R2 server?

@usahitya Yes, it should work also with Windows2008R2, but be aware that we mainly test on 2012. Please let us know in case there are some issues.

1 Like

Hi Thanks for your answer @ruflin
Is there any document about how to install in Windows system. I didn't found any from this page.

Best is to directly download the windows binary here and install it:

@usahitya We are also working on improving the docs for the windows setup.