Filebeat connection to elasticsearch Error

Hello, I'm not sure what is your question. Since your setup is using https certainly you need to have TLS certificates setup correctly. When using in-house root CA you need to provide it to the filebeat to be able to validate the TLS certificate chain, also note that your leaf certificate will have to include the IP '` otherwise you have to use a matching DNS name instead of the IP. It's also possible to explicitly disable host name verification in ssl settings.