Filebeat don't send files without errors in log

Hi forum,

I apologize for having to spam again.

However, I just can't find the solution.

I have a newly installed elasticsearch + kibana + filebeat.
Installed the latest 8.x packages from the Debian repositories.

I have no error messages in the logs and everything works fine so far.

The only thing is that filebeat does not send any data to elasticsearch.
There is no index available.

I also cannot find a Filebeat dashboard. Or activate it.


###################### Filebeat Configuration Example #########################

# This file is an example configuration file highlighting only the most common
# options. The filebeat.reference.yml file from the same directory contains all the
# supported options with more comments. You can use it as a reference.
# You can find the full configuration reference here:

# For more available modules and options, please see the filebeat.reference.yml sample
# configuration file.

# ============================== Filebeat inputs ===============================


# Each - is an input. Most options can be set at the input level, so
# you can use different inputs for various configurations.
# Below are the input-specific configurations.

# filestream is an input for collecting log messages from files.
- type: filestream

  # Unique ID among all inputs, an ID is required.
  id: my-filestream-id

  # Change to true to enable this input configuration.
  enabled: true

  # Paths that should be crawled and fetched. Glob based paths.
    - /var/log/*.log
    #- c:\programdata\elasticsearch\logs\*

  # Exclude lines. A list of regular expressions to match. It drops the lines that are
  # matching any regular expression from the list.
  # Line filtering happens after the parsers pipeline. If you would like to filter lines
  # before parsers, use include_message parser.
  #exclude_lines: ['^DBG']

  # Include lines. A list of regular expressions to match. It exports the lines that are
  # matching any regular ex
# ============================== Filebeat modules ==============================

  # Glob patter.n for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 10s

# ======================= Elasticsearch template setting =======================

  index.number_of_shards: 1
  #index.codec: best_compression
  #_source.enabled: false

# ================================== General ===================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.

# The tags of the shipper are included in their field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#  env: staging

# ================================= Dashboards =================================
# These settings control loading the sample dashboards to the Kibana index. Loading
# the dashboards is disabled by default and can be enabled either by setting the
# options here or by using the `setup` command.
#setup.dashboards.enabled: false

# The URL from where to download the dashboard archive. By default, this URL
# has a value that is computed based on the Beat name and version. For released
# versions, this URL points to the dashboard archive on the
# website.

# =================================== Kibana ===================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  host: "localhost:5601"

  # Kibana Space ID
  # ID of the Kibana Space into which the dashboards should be loaded. By default,
  # the Default Space will be used.

# =============================== Elastic Cloud ================================

# These settings simplify using Filebeat with the Elastic Cloud (

# The setting overwrites the `output.elasticsearch.hosts` and
# `` options.
# You can find the `` in the Elastic Cloud web UI.

# The cloud.auth setting overwrites the `output.elasticsearch.username` and
# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.

# ================================== Outputs ===================================

# Configure what output to use when sending the data collected by the beat.

# ---------------------------- Elasticsearch Output ----------------------------
  # Array of hosts to connect to.
  hosts: ["localhost:9200"]

  # Protocol - either `http` (default) or `https`.
  protocol: "https"

  # Authentication credentials - either API key or username/password.
  #api_key: ""
  username: "elastic"
  password: "elastic_superuser_pw"

    enabled: true
    ca_trusted_fingerprint: "auto_generated_ca_trusted_fingerprint"

# ------------------------------ Logstash Output -------------------------------
  # The Logstash hosts
  #hosts: ["localhost:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

  # Certificate for SSL client authentication

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"

# ================================= Processors =================================
  - add_host_metadata:
      when.not.contains.tags: forwarded
  - add_cloud_metadata: ~
  - add_docker_metadata: ~
  - add_kubernetes_metadata: ~

# ================================== Logging ===================================

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
#logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors, use ["*"]. Examples of other selectors are "beat",
# "publisher", "service".
#logging.selectors: ["*"]

# ============================= X-Pack Monitoring ==============================
# Filebeat can export internal metrics to a central Elasticsearch monitoring
# cluster.  This requires xpack monitoring to be enabled in Elasticsearch.  The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
#monitoring.enabled: false

# Sets the UUID of the Elasticsearch cluster under which monitoring data for this
# Filebeat instance will appear in the Stack Monitoring UI. If output.elasticsearch
# is enabled, the UUID is derived from the Elasticsearch cluster referenced by output.elasticsearch.

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch outputs are accepted here as well.
# Note that the settings should point to your Elasticsearch *monitoring* cluster.
# Any setting that is not set is automatically inherited from the Elasticsearch
# output configuration, so if you have the Elasticsearch output configured such
# that it is pointing to your Elasticsearch monitoring cluster, you can simply
# uncomment the following line.

# ============================== Instrumentation ===============================

# Instrumentation support for the filebeat.
    # Set to true to enable instrumentation of filebeat.
    #enabled: false

    # Environment in which filebeat is running on (eg: staging, production, etc.)

    # Environment in which filebeat is running on (eg: staging, production, etc.)
    #environment: ""

    # APM Server hosts to report instrumentation results to.
    #  - http://localhost:8200

    # API Key for the APM Server(s).
    # If api_key is set then secret_token will be ignored.

    # Secret token for the APM Server(s).

# ================================= Migration ==================================

# This allows to enable 6.7 migration aliases
#migration.6_to_7.enabled: true

Does anyone have any ideas?


did you try the test commands...

filebeat test output

Also, of course there are logs :slight_smile: You may just be having trouble finding them...

I would suggest to download the filebeat from the tar.gz use your config and try running filebeat in the foregroup=nd (not with systemctl) and watch it start up (stop the systmctl first as you can only run 1 filebeat at a time)

Hi @stephenb,

I apologize, I expressed myself incorrectly.

Of course there are logs. But only info messages, no errors.

filebeat test output:
elasticsearch: https://localhost:9200...
  parse url... OK
    parse host... OK
    dns lookup... OK
    addresses:, ::1
    dial up... OK
    security: server's certificate chain verification is enabled
    handshake... OK
    TLS version: TLSv1.3
    dial up... OK
  talk to server... OK
  version: 8.10.4

I could see that there was a signal.

In Index Management under Data Streams I can see an entry from Filebeat. However, there is still no index.

Did you run setup before trying to start filbeat?

filebeat setup -e

Are there any logs to be read at that path? /var/log/*.log

Were the logs read already?

There is no filbeat dashboard

Go To Kibana - Discover and set Time Range to Last 30 days.

In Kibana Dev Tools run

GET _cat/indices?v

If nothing You can try deleting the filebeat registry which keeps track of what is ready

stop filebeat

sudo rm -fr /var/lib/filebeat/*

start filebeat

Just because there are no errors in the filebeat log does not mean there are no helpful logs

Thanks for all the tips, @stephenb.

I mean this dashboard:

And I got this in an installation, which was some time ago, by adding the integration.
That's why I haven't run filebeat setup -e yet.

However, I have now done so. I have received some INFO output but no errors.
Otherwise no change is visible.

There are logs with content in the specified path /var/log/*.log.

rm -fr /var/lib/filebeat/* Did not produce any changes either.

Partial communication takes place.

Under Stack Management -> index Management -> Data Streams I can see a Filebeat stream.
This was also updated after entering the commands.

However, an index is not created automatically.

I only have the following three there:

  • .kibana-observability-ai-assistant-conversations-000001
  • .kibana-observability-ai-assistant-kb-000001
  • metrics-endpoint.metadata_current_default

The log files of elasticsearch, kibana and filebeat have no error entries.

That requires you using the filebeat system module

Disable your current filestream, that is for generic logs not the System module.
enabled: false

See the Quick Start Here

And where is says

filebeat modules enable nginx

do the system module instead

filebeat modules enable system

edit the


Make sure it is enabled with the correct paths

and Follow the rest of the quick start steps...

Since you may have already loaded the logs you may need to clear the regissty again

sudo rm -fr /var/lib/filebeat/*

Thank you very much for your help.

It looks very good so far.
The mentioned dashboard (and many more) are now available.

However, it is still empty.

I have done the tasks you mentioned before and also deleted the data stream.
This has recreated itself.

But still no index.

Go to Kibana - Dev Tools

GET _cat/indices?v

This is the result I get:

However, the dashboard remains empty and there is no index.

Please don't post pictures of text.... they are hard to read, and some people can not see them.

See the bottom entry; that means no logs have been sent 0 documents.

Can you share your modules.d/system.yml

Are there log files on your system where the system.yml is pointing to?

I assume you are stopping and starting filebeat after these configuration changes?

Did you run

sudo rm -fr /var/lib/filebeat/*

If you have done all this ... then ... the answer is in the filebeat logs...

Sorry, I'm paying attention to the point about the pictures.

I still have a mistake somewhere.

# Module: system
# Docs:

- module: system
  # Syslog
    enabled: true

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    var.paths: ["/var/log/journal*"]

  # Authorization logs
    enabled: false

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    #var.paths: ""

I have now done everything again using the following procedure:

  • stop filebeat
  • In filebeat.yml checked if 'enabled: false'
  • rm -fr /var/lib/filebeat/*
  • deleted the file stream from filebeat
  • restart the computer (filebeat starts with it)

No new data stream has been generated. No Index. No Data on the dashboard.

However, no errors in the log.
What else should I look out for, I don't want to annoy you with all the logs.

Perhaps take that out and let file be choose the correct path as the default.

I don't think Journal files aren necessarily the same syslog, This module is looking for syslog format

Journal files also come from systemD and they do indeed have a special format.

How do I activate the default path? Deactivate var.paths or

var.paths: [" "]

Do you have an alternative for my local log files from linux if it doesn't work?

Leave that line out completely... or comment it out like it came

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.

Exactly what OS? I would guess

var.paths: ["/var/log/syslog*"]

You will need to look.

root@stephenb-es-8-test:/var/log# uname -a
Linux stephenb-es-8-test 5.15.0-1038-gcp #46~20.04.1-Ubuntu SMP Fri Jul 14 09:48:19 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux
root@stephenb-es-8-test:/var/log# cd /var/log/
root@stephenb-es-8-test:/var/log# pwd
root@stephenb-es-8-test:/var/log# ls syslog*
syslog  syslog.1  syslog.2.gz  syslog.3.gz  syslog.4.gz  syslog.5.gz  syslog.6.gz  syslog.7.gz

I do not have a syslog. Only the journal.

I use Linux Debian 6.1.0-13-amd64

Well, that is a problem then.

The dashboards you reference are specific for Sylogs / Syslog Format from the system module

If you want to read in journald then you should look at

But as far as I know, there are no pre-made dashboards for journald but you can certainly build your own.

1 Like

Thank you for your answer and all the tips.

I'll have a look at it at the weekend. However, an initial test has shown that data is constantly coming in.

Should work.

Thanks again.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.