Filebeat fails to start with filebeat-god but works with filebeat directly


(Stanislav Antic) #1

I'm using CentOS 6.8 and have installed filebeat (version 1.3.1). My configuration is:

---
filebeat:
  prospectors: [{"paths": ["/var/log/*.log"], "input_type": "log"}]
  registry_file: /var/lib/filebeat/registry


output:
  {"console": {"pretty": false}}

shipper:

logging:
  to_syslog: false
  to_files: true
  files:
    path: /var/log/beat/
    name: filebeat

    # Configure log file size limit. If limit is reached, log file will be
    # automatically rotated
    rotateeverybytes: 10485760 # = 10MB

    # Number of rotated log files to keep. Oldest files will be deleted first.
    keepfiles: 7

  # Enable debug output for selected components. To enable all selectors use ["*"]
  # Other available selectors are beat, publish, service
  # Multiple selectors can be chained.
  #selectors: [ ]

  # Sets log level. The default log level is error.
  # Available log levels are: critical, error, warning, info, debug
  #level: error

When starting with service script it just exits. If I run filebeat-god with '-f' (foreground option) it works:

filebeat-god -f -r / -n -p /var/run/filebeat.pid -- /usr/bin/filebeat -c /etc/filebeat/filebeat.yml

And when I run it with filebeat command directly:

/usr/bin/filebeat -c /etc/filebeat/filebeat.yml

My guess that this is bug.


(Stanislav Antic) #2

Problem here was because 'filebeat-god' (https://github.com/tsg/go-daemon) closes stdin, stdout, stderr. This won't work with console out. Some error message in log would be really usefull in this case.


(Steffen Siering) #3

Agree on the error message being helpfull. It has been added to upcoming 5.0 beta1 release.


(system) #4

This topic was automatically closed after 21 days. New replies are no longer allowed.