It doesn't seem to be doing anything


(David Banks) #1

I have FileBeat installed as a service and I've set the following config:

filebeat:
  prospectors:
    -
      paths:
        - C:\LogFiles\log.log

      input_type: filebeat

  registry_file: "C:/ProgramData/filebeat/registry"

output:

  logstash:
    hosts: ["XX.XX.XX.XX:5044"]

shipper:

logging:

  files:
    path: C:\fileBeatLogs
    rotateeverybytes: 10485760 # = 10MB
  level: error

I've also tried the paths with forward slashes

The registry file is being changed when I start the service, but not at any other times and there are no logs being written to C:\fileBeatLogs\.

If I run FileBeat from the exe I get no output at all, even with the debug on C:\filebeat-1.2.3-windows>filebeat -c filebeat.yml -configtest -d "*"


(Andrew Kroh) #2

You need to use the -e option otherwise the logging will be sent to the file you defined. See https://www.elastic.co/guide/en/beats/filebeat/current/enable-filebeat-debugging.html

That's not a valid option. See https://www.elastic.co/guide/en/beats/filebeat/current/configuration-filebeat-options.html#_input_type


(system) #3

This topic was automatically closed after 21 days. New replies are no longer allowed.