Filebeat Input Config Error

I am new to all of this so bear with me.

I have set up an instance on elastic cloud and am attempting to import logs from my windows VM machine.

I have the config file setup for the most part but cant find where to import logs from within my windows system.


Each - is an input. Most options can be set at the input level, so

you can use different inputs for various configurations.

Below are the input specific configurations.

  • type: log

    Change to true to enable this input configuration.

    enabled: true

    Paths that should be crawled and fetched. Glob based paths.

    #- /var/log/*.log

    • c:\programdata\elasticsearch\logs*

Where are logs stored on Windows that i can point the file path above to grab from?

Configuring input :

Please change the location based on your machine setup (you may want to put the paths in ' ' to avoid Windows // )

Filebeat directory layout

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.