Filebeat setup -e fails Error kibana fail to get version

I have Kibana and elastic search running, in a non clustered local environment.
This has been running filebeat for maybe a year or a little less.
Between a test machine and a Elk server.
Its a pretty basic config, logstash is not configured and no security
(its on a segment where no-one has access to except 2 admins).

So a year later it was decided to make more use of it, and add another client to the ELK
So I installed filebeat, and tried to run filebeat setup -e
The first time it failed, because newly installed filebeat had stuff newer than the ELK server
So i decided to upgrade ELK, the upgrade process warned me of some altered .yml files :

  • kibana.yml
  • elasticsearch.yml
  • logstash.yml

I decided to keep those (as they contained some specific tunings)
Mainly server urls and port settings, i tought it would be normal to keep them when upgrading..
So then I re tried on the other machine filebeat setup -e
I no longer had the problems with newer local filebeat but i got different errors now:

Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET request to fails: fail to execute the HTTP GET request: Get "": dial tcp connect: connection refused. Response: .

I have no idea what causes this some help would be great.
Might it be because i kept those .yml files ?, can they be downloaded seperatly so i can compare them if something goes wrong ?.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.