First search Request on Elasticsearch is slow


Having an issue on elasticsearch, my first request to search in elastic is slow. Once any term gets searched then it becomes fast. I have researched about this and get to know the solution is to change the index settings for refresh_interval and I have done the changes and changed the idle after settings to:

  "settings": {
    "": "3600s" 

and refresh_interval to:

  "index": {
    "refresh_interval": "3600s" 

But my problem is not resolved.

Note that I am searching on multiple indices. Also I have updated the same settings for all indices.

You set to refresh the index every hour. You should may be lower this to 1s.

But, I'd not change those settings.

Instead, when you first start your application, just send some random requests to the indices so this will warmup the cluster.

If this can not fit your use case, could you explain what are you using Elasticsearch for?

after some time when the cluster is idle then first search is taking time. That's why I change the idle.after setting.
I am using elasticsearch for text search purpose.

It is not a proper that every we need to warm up the cluster so it works properly..

You could also fire a request every x minutes to keep the cluster warm.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.