Fleet enrollment is done but doesn't appear on Security > Administration > Endpoints

Hi all!
I'm trying to enroll Elastic Agent on Fleet.
Kibana and Elasticsearch are on Windows 10 WSL Ubuntu 16.04 and Elastic Agent is on Windows 10.
I'm using self-signed certs so I imported certificates as root trusted certificate.
I do see Agent on Fleet and data sets on data streams but no hosts appear on Endpoints.
Is there any solution of this case?
I'm gonna test again by installing KB and ES on Windows 10 by the way.



Tried on windows 10 but still doesn't appear on Security > Administration > Endpoints :thinking:

Hi @roh

I'm sorry to hear you're having trouble. Can you follow the instructions here Endpoints are enrolling stuck message to see if there might be an issue with how your root certificate was imported?

Our of curiosity, what Agent version are you using?

Used latest version, 7.10.1.

I'm curious I used correct self-signed CA.
I used CA made from this command.

./bin/elasticsearch-certutil ca

I already followed instructions in Endpoints are enrolling stuck message, but still didn't work.

I'v succeeded before with not using HTTPS security... maybe I should try that once more.

@roh, this is bummer, sorry for all the trouble.

Can you confirm that the self-signed CA was added as Local Machine?
Others have had trouble by choosing the default, Current User.

Also, it's necessary for Endpoint Security to be restarted after adding a new CA to the system.

If you are sure about those two things we will need to see logs (or snippets of logs) to debug this beast.

Elastic Endpoint is installed in c:\Program Files\Elastic\Endpoint . Logs are written to c:\Program Files\Elastic\Endpoint\state\log\endpoint-*.log . Are they any errors in there? If so, please post them.

I too have this same issue logs are shipping and everything works but the administration page in Security still shows agents are enrolling. Although the enrollment completed successfully days ago. For now I just change the endpoint security settings by going and editing the Elastic Security policy and clicking show advance settings it then successfully takes me to Security settings page but I want to go via Elastic Security App it keeps saying enrollment in process.