Fleet Server No Data Stream

Hi All ,

When installed Fleet server with quick start.

the fleet server cannot receive any data themselves , same as system.

install command :

sudo ./elastic-agent install \
  --fleet-server-es=https://172.16.**.**:9200 \
  --fleet-server-policy=fleet-server-policy \

Please help. Thanks.

Hi @NathanLau,

Could you share the command used to enroll the fleet server and some logs of the elastic agent?

It would be very helpful to understand what's going on in your config.


Hi Cristina ,

Here is install code.

sudo ./elastic-agent install \
  --fleet-server-es=https://172.16.**.**:9200 \
  --fleet-server-service-token=AAEAAWVsYXN0aWMvZmxlZX**********************************dIRVZUUk9aWEIzeFJGa0NvZw \
  --fleet-server-policy=fleet-server-policy \

Because I am using docker to build it , I think the yml file point to my docker ip address ( but it's may fault.

What should I do ? edit the yml file to point the correct ip address?

Hi @Cristina_Amico

Any Suggestions?


Hi Nathan,

--fleet-server-es should point to the Elasticsearch URL and should also be configured in Fleet Settings tab.

Under Outputs, click on Add output and select a new ES output, the host URL should be the same passed that is then passed to the enroll command:

By looking at the provided logs it seems that the fleet server is not able to reach Elasticsearch, so you can check if you can reach it with this command:


Could you check again your configuration, check that you can reach ES and then try again?


Hi @Cristina_Amico ,

I already direct change the ip address from docker IP to my VM.

Thanks. it's work. But in your way , it's cannot set it to default Agent.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.