Fresh install not getting latest beats input plugin


(Jeffrey Ollie) #1

I'm building a Logstash container but it isn't getting the latest beats plugin. The container is being built from scratch each time, but the plugin install command installs version 0.9.2. A subsequent plugin update command tells me that it's going to update to 2.0.2 but actually installs 0.9.6:

You are updating logstash-input-beats to a new version 2.0.2, which may not be compatible with 0.9.2. are you sure you want to proceed (Y/N)?
y
Updating logstash-input-beats
Updated logstash-input-beats 0.9.2 to 0.9.6

Is this a known problem?


(system) #2