Fresh install of 7.4 Kibana - Kibana does not start listening on expected interface

I installed Elasticsearch and Kibana 7.4 on a VM running Ubuntu 18.04. Following the instructions in the guide for that version. After finishing I set this single option in kibana.yml

From what I have read this should cause Kibana to start listening on that address. However a netstat shows it is only still listening to localhost. I've restarted the service, the VM, and tried setting the value for to the VMs IP address, with and without quotes. In my logs, the service explicitly states its running at http://localhost:5601

I have also left the default for the and tried adjusting the port. And the server will not recognize this change either, remaining 5601.

Am I missing something?

Sounds like your Kibana instance is not loading your kibana.yml file.

To test that your Kibana instance is not loading your kibana.yml, put a configuration that does not exist, like not_a_valid_config: true in your kibana.yml. Your kibana instance should fail with invalid configurations. If it does not fail then your kibana instance is not loading your kibana.yml

Thanks for your help Nathan.

I placed that bad option in the /etc/kibana.yml file and it did indeed throw an exception, but not for the line I placed it in the file.

Prior to your response I also tried installing as 7.3 in a clean VM and the issue occurred again.

I used the instructions here to install it on this Ubuntu VM:

So, I had a co-worker lend a second set of eyes. He noticed that every other configuration option had a whitespace after the colon. I added a whitespace, and it started the listener on the correct network/interface.

I did not realize the yaml tokenizer was that picky. Sorry for wasting your time. Thanks Nathan.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.