First time installing Kibana facing issue


#1

This is my first time installing Kibana on Ubuntu server OS using apt-get and I am facing a problem, can anyone provide guidance?

I am not able to see Kibana from another device browser using http://IP:5601

When I try to access locally on the server which has Kibana installed, I am seeing this

kibana%201

I check the Kibana service and it seems to be running
kibana%202

I also cannot find Kibana logs in /var/log

Need some tips on how to get Kibana to work...


(Mark Walkom) #2

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them :slight_smile:

Did you change server.host? See https://www.elastic.co/guide/en/kibana/current/settings.html


#3

Noted, will not post pictures of text in the future.

server.host is set to localhost.


(Mark Walkom) #4

Ok, so Kibana will only ever listen to loopback addresses, not external ones.


#5

Do you mean that i need to set server.host to the IP address of the server for it work?


(Mark Walkom) #6

If you want to be able to access it from other hosts, yep.


(Vikas) #7

provide this:
elasticsearch.url: "IP_Address:port_no."

#port no to be used specially when the elasticsearch is running at different port no except 9200.If elasticsearch is using 9200 thn no need to provide:

elasticsearch.url: "IP_Address"

next is server host
server.host: "Ip_address of the server on which kibana instance is"


#8

I edited the Kibana yml file:
#server.host: "192.168.1.228"
#elasticsearch.url: "http://192.168.1.228:9200"

then I am getting this error:
poodle@ubuntuserver:/$ curl -X GET "192.168.1.228:9200"
curl: (7) Failed to connect to 192.168.1.228 port 9200: Connection refused
poodle@ubuntuserver:/$ curl -X GET "192.168.1.228:5601"
curl: (7) Failed to connect to 192.168.1.228 port 5601: Connection refused


(Vikas) #9

Can you check, Is your elasticsearch running? and please remove # in yml,it means a comment.


#10

Yes, I think elasticsearch is running, I got a response form port 9200 using curl...

poodle@ubuntuserver:~$ curl -X GET "localhost:5601"
curl: (7) Failed to connect to localhost port 5601: Connection refused
poodle@ubuntuserver:~$ curl -X GET "localhost:9200"
{
"name" : "ur_Ay9a",
"cluster_name" : "elasticsearch",
"cluster_uuid" : "hHsiaHCwSXSkURPB_DoHDw",
"version" : {
"number" : "6.2.4",
"build_hash" : "ccec39f",
"build_date" : "2018-04-12T20:37:28.497551Z",
"build_snapshot" : false,
"lucene_version" : "7.2.1",
"minimum_wire_compatibility_version" : "5.6.0",
"minimum_index_compatibility_version" : "5.0.0"
},
"tagline" : "You Know, for Search"
}
poodle@ubuntuserver:~$ curl -X GET "192.168.1.228:5601"
curl: (7) Failed to connect to 192.168.1.228 port 5601: Connection refused
poodle@ubuntuserver:~$ curl -X GET "192.168.1.228:9200"
curl: (7) Failed to connect to 192.168.1.228 port 9200: Connection refused

I don't see any logfiles created for Kibana...
poodle@ubuntuserver:~$ ls /var/log
alternatives.log btmp dpkg.log installer lastlog ufw.log
apt cloud-init.log elasticsearch journal lxd unattended-upgrades
auth.log cloud-init-output.log faillog kern.log syslog wtmp
bootstrap.log dist-upgrade fontconfig.log landscape tallylog

I've removed most of the comments, this is my yaml file:
poodle@ubuntuserver:~$ sudo vim /etc/kibana/kibana.yml

#Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

#Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
#The default is 'localhost', which usually means remote machines will not be able to connect.
#To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "192.168.1.228"

#Enables you to specify a path to mount Kibana at if you are running behind a proxy. This only affects
#the URLs generated by Kibana, your proxy is expected to remove the basePath value before forwarding requests
#to Kibana. This setting cannot end in a slash.
#server.basePath: ""

#The maximum payload size in bytes for incoming server requests.
server.maxPayloadBytes: 1048576

#The Kibana server's name. This is used for display purposes.
server.name: "ubuntuserver"

#The URL of the Elasticsearch instance to use for all your queries.
elasticsearch.url: "http://192.168.1.228:9200"

#When this setting's value is true Kibana uses the hostname specified in the server.host
#setting. When the value of this setting is false, Kibana uses the hostname of the host
#that connects to this Kibana instance.
elasticsearch.preserveHost: true

#Kibana uses an index in Elasticsearch to store saved searches, visualizations and
#dashboards. Kibana creates a new index if the index doesn't already exist.
kibana.index: ".kibana"

#The default application to load.
kibana.defaultAppId: "home"

#If your Elasticsearch is protected with basic authentication, these settings provide
#the username and password that the Kibana server uses to perform maintenance on the Kibana
#index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
#is proxied through the Kibana server.
#elasticsearch.username: "user"
#elasticsearch.password: "pass"

#Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
#These settings enable SSL for outgoing requests from the Kibana server to the browser.
#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

#Optional settings that provide the paths to the PEM-format SSL certificate and key files.
#These files validate that your Elasticsearch backend uses the same key files.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

#Optional setting that enables you to specify a path to the PEM file for the certificate
#authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

#To disregard the validity of SSL certificates, change this setting's value to 'none'.
#elasticsearch.ssl.verificationMode: full

#Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
#the elasticsearch.requestTimeout setting.
elasticsearch.pingTimeout: 1500

#Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
#must be a positive integer.
elasticsearch.requestTimeout: 30000

#List of Kibana client-side headers to send to Elasticsearch. To send no client-side
#headers, set this value to [] (an empty list).
elasticsearch.requestHeadersWhitelist: [ authorization ]

#Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
#by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
elasticsearch.customHeaders: {}

#Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
elasticsearch.shardTimeout: 0

#Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.
elasticsearch.startupTimeout: 5000

#Specifies the path where Kibana creates the process ID file.
pid.file: /var/run/kibana.pid

#Enables you specify a file where Kibana stores log output.
logging.dest: stdout

#Set the value of this setting to true to suppress all logging output.
logging.silent: false

#Set the value of this setting to true to suppress all logging output other than error messages.
logging.quiet: false

#Set the value of this setting to true to log all events, including system usage information
#and all requests.
logging.verbose: false

#Set the interval in milliseconds to sample system and process performance
#metrics. Minimum is 100ms. Defaults to 5000.
ops.interval: 5000

#The default locale. This locale can be used in certain circumstances to substitute any missing
#translations.
i18n.defaultLocale: "en"


(Vikas) #11
  1. check in your elasticsearch.yml what network.host you have provided.it should be 192.168.1.228.
    2)run this on your browser http://192.168.1.228:5601
    (first check is your elasticsearch is running by running http://192.168.1.228:9200 on your browser.you will get a json doc.if you get thn its ok,otherwise something wrong.)

(system) #12

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.