FS-River pause the index search?

Hi All,

I'm working with fs-river to index the local file system. The fs-river run
on the thread at particular interval for eg. 180000 [every 3 min]. Can we
pause/stop the index, but still able to run search query? Using curl
command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we open
the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit.kamboj@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river run on the thread at particular interval for eg. 180000 [every 3 min]. Can we pause/stop the index, but still able to run search query? Using curl command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

It's now added in FSRiver and will be part of 0.2.0 release: https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato david@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit.kamboj@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river run on the thread at particular interval for eg. 180000 [every 3 min]. Can we pause/stop the index, but still able to run search query? Using curl command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which contain
some files and pdf. it is running at interval of 2 min. When i call the
command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i tired
to update the document and got the updated result after 2 min. Does* _stop*means that the river will stop the indexing the particular index or
something else?

just to log the result, i run the following curl command to verify my
results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" :
{"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:

It's now added in FSRiver and will be part of 0.2.0 release:
https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato <da...@pilato.fr <javascript:>> a
écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can open
an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh <ajit....@gmail.com <javascript:>>
a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river run
on the thread at particular interval for eg. 180000 [every 3 min]. Can we
pause/stop the index, but still able to run search query? Using curl
command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we open
the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh ajit.kamboj@gmail.com a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which contain some files and pdf. it is running at interval of 2 min. When i call the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty
{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i tired to update the document and got the updated result after 2 min. Does _stop means that the river will stop the indexing the particular index or something else?

just to log the result, i run the following curl command to verify my results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty
{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" : {"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:
It's now added in FSRiver and will be part of 0.2.0 release: https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river run on the thread at particular interval for eg. 180000 [every 3 min]. Can we pause/stop the index, but still able to run search query? Using curl command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi,

No, i just imported the git project and compiled , then replaced the jar
file to target jar file. may be mistake on my side, i just saw the new
documentation about stop process and tried it :{

Well i have tried removing pretty from the get the same result.

Thanks

On Wednesday, 24 April 2013 15:44:48 UTC+1, David Pilato wrote:

Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh <ajit....@gmail.com <javascript:>>
a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which
contain some files and pdf. it is running at interval of 2 min. When i call
the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i tired
to update the document and got the updated result after 2 min. Does* _stop

  • means that the river will stop the indexing the particular index or
    something else?

just to log the result, i run the following curl command to verify my
results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" :
{"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/
172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:

It's now added in FSRiver and will be part of 0.2.0 release:
https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can open
an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river
run on the thread at particular interval for eg. 180000 [every 3 min]. Can
we pause/stop the index, but still able to run search query? Using curl
command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we open
the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Try to use the latest from here: https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/

This should work:

curl localhost:9200/_river/wikidocs/_stop

Just to make sure, can you do the following?

curl localhost:9200/_river/_search?q=*

I would like to check the river id.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 24 avr. 2013 à 16:55, Ajitpal Singh ajit.kamboj@gmail.com a écrit :

Hi,

No, i just imported the git project and compiled , then replaced the jar file to target jar file. may be mistake on my side, i just saw the new documentation about stop process and tried it :{

Well i have tried removing pretty from the get the same result.

Thanks

On Wednesday, 24 April 2013 15:44:48 UTC+1, David Pilato wrote:
Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which contain some files and pdf. it is running at interval of 2 min. When i call the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty
{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i tired to update the document and got the updated result after 2 min. Does _stop means that the river will stop the indexing the particular index or something else?

just to log the result, i run the following curl command to verify my results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty
{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" : {"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:
It's now added in FSRiver and will be part of 0.2.0 release: https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river run on the thread at particular interval for eg. 180000 [every 3 min]. Can we pause/stop the index, but still able to run search query? Using curl command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I'm just running this curl command mentioned , on the previous code i just
edited for bit more logging and the output is

{

"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 1,
"successful" : 1,
"failed" : 0
},
"hits" : {
"total" : 3,
"max_score" : 1.0,
"hits" : [ {
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_meta",
"_score" : 1.0, "_source" : {
"type": "fs",
"fs": {
"name": "Test",
"url": "/home/usernode005/share/",
"update_rate": 120000,
"includes": "*.txt , *.pdf"
},
"index": {
"index": "wikidocs",
"type": "doc",
"bulk_size": 50
}
}
}, {
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_score" : 1.0, "_source" :
{"ok":true,"node":{"id":"WhKV09-hRLeV3AY1P-r1xA","name":"Elastic-Master","transport_address":"inet[/172.16.51.128:9300]"}}
}, {
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_lastupdated",
"_score" : 1.0, "_source" :
{"fs":{"feedname":"Test","lastdate":"2013-04-24T13:59:45.621Z","docadded":7,"docdeleted":0}}
} ]
}
}

Just download the jar from the link and going to try with it.

thanks :}

On Wednesday, 24 April 2013 16:17:54 UTC+1, David Pilato wrote:

Try to use the latest from here:
https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/

This should work:

curl localhost:9200/_river/wikidocs/_stop

Just to make sure, can you do the following?

curl localhost:9200/_river/_search?q=*

I would like to check the river id.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:55, Ajitpal Singh <ajit....@gmail.com <javascript:>>
a écrit :

Hi,

No, i just imported the git project and compiled , then replaced the jar
file to target jar file. may be mistake on my side, i just saw the new
documentation about stop process and tried it :{

Well i have tried removing pretty from the get the same result.

Thanks

On Wednesday, 24 April 2013 15:44:48 UTC+1, David Pilato wrote:

Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which
contain some files and pdf. it is running at interval of 2 min. When i call
the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i
tired to update the document and got the updated result after 2 min. Does

  • _stop* means that the river will stop the indexing the particular
    index or something else?

just to log the result, i run the following curl command to verify my
results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" :
{"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/
172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:

It's now added in FSRiver and will be part of 0.2.0 release:
https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can
open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river
run on the thread at particular interval for eg. 180000 [every 3 min]. Can
we pause/stop the index, but still able to run search query? Using curl
command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we
open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi,

Just a simple question, Does the river _stop the particular river only?
Suppose if i have two river with localdoc1, localdoc2, when i call
localdoc2/_stop in curl. then it will only stop the localdoc2 river only?

thanks :}

On Wednesday, 24 April 2013 16:17:54 UTC+1, David Pilato wrote:

Try to use the latest from here:
https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/

This should work:

curl localhost:9200/_river/wikidocs/_stop

Just to make sure, can you do the following?

curl localhost:9200/_river/_search?q=*

I would like to check the river id.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:55, Ajitpal Singh <ajit....@gmail.com <javascript:>>
a écrit :

Hi,

No, i just imported the git project and compiled , then replaced the jar
file to target jar file. may be mistake on my side, i just saw the new
documentation about stop process and tried it :{

Well i have tried removing pretty from the get the same result.

Thanks

On Wednesday, 24 April 2013 15:44:48 UTC+1, David Pilato wrote:

Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which
contain some files and pdf. it is running at interval of 2 min. When i call
the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i
tired to update the document and got the updated result after 2 min. Does

  • _stop* means that the river will stop the indexing the particular
    index or something else?

just to log the result, i run the following curl command to verify my
results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" :
{"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/
172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:

It's now added in FSRiver and will be part of 0.2.0 release:
https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can
open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river
run on the thread at particular interval for eg. 180000 [every 3 min]. Can
we pause/stop the index, but still able to run search query? Using curl
command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we
open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Yes. It only pause actually one single river instance.
The river is still running but does not try to fetch document anymore. The river only checks every x seconds if you restarted or not.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 25 avr. 2013 à 10:53, Ajitpal Singh ajit.kamboj@gmail.com a écrit :

Hi,

Just a simple question, Does the river _stop the particular river only? Suppose if i have two river with localdoc1, localdoc2, when i call localdoc2/_stop in curl. then it will only stop the localdoc2 river only?

thanks :}

On Wednesday, 24 April 2013 16:17:54 UTC+1, David Pilato wrote:
Try to use the latest from here: https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/

This should work:

curl localhost:9200/_river/wikidocs/_stop

Just to make sure, can you do the following?

curl localhost:9200/_river/_search?q=*

I would like to check the river id.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 24 avr. 2013 à 16:55, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

No, i just imported the git project and compiled , then replaced the jar file to target jar file. may be mistake on my side, i just saw the new documentation about stop process and tried it :{

Well i have tried removing pretty from the get the same result.

Thanks

On Wednesday, 24 April 2013 15:44:48 UTC+1, David Pilato wrote:
Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which contain some files and pdf. it is running at interval of 2 min. When i call the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty
{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i tired to update the document and got the updated result after 2 min. Does _stop means that the river will stop the indexing the particular index or something else?

just to log the result, i run the following curl command to verify my results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty
{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" : {"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:
It's now added in FSRiver and will be part of 0.2.0 release: https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river run on the thread at particular interval for eg. 180000 [every 3 min]. Can we pause/stop the index, but still able to run search query? Using curl command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks for clarification.

Actually i was trying to update the fsriver code before _start, _stop
implementation. I just added the ManageriverAction class and update the run
code in FSParser class to test something. But the _stop is still giving the
old json that i have mentioned earlier, is i'm missing something?

Thanks

On Thursday, 25 April 2013 10:37:18 UTC+1, David Pilato wrote:

Yes. It only pause actually one single river instance.
The river is still running but does not try to fetch document anymore. The
river only checks every x seconds if you restarted or not.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 25 avr. 2013 à 10:53, Ajitpal Singh <ajit....@gmail.com <javascript:>>
a écrit :

Hi,

Just a simple question, Does the river _stop the particular river only?
Suppose if i have two river with localdoc1, localdoc2, when i call
localdoc2/_stop in curl. then it will only stop the localdoc2 river only?

thanks :}

On Wednesday, 24 April 2013 16:17:54 UTC+1, David Pilato wrote:

Try to use the latest from here:
https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/

This should work:

curl localhost:9200/_river/wikidocs/_stop

Just to make sure, can you do the following?

curl localhost:9200/_river/_search?q=*

I would like to check the river id.

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:55, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

No, i just imported the git project and compiled , then replaced the jar
file to target jar file. may be mistake on my side, i just saw the new
documentation about stop process and tried it :{

Well i have tried removing pretty from the get the same result.

Thanks

On Wednesday, 24 April 2013 15:44:48 UTC+1, David Pilato wrote:

Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your
package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which
contain some files and pdf. it is running at interval of 2 min. When i call
the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i
tired to update the document and got the updated result after 2 min. Does

  • _stop* means that the river will stop the indexing the particular
    index or something else?

just to log the result, i run the following curl command to verify my
results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" :
{"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/
172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:

It's now added in FSRiver and will be part of 0.2.0 release:
https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can
open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river
run on the thread at particular interval for eg. 180000 [every 3 min]. Can
we pause/stop the index, but still able to run search query? Using curl
command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we
open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I checked:

$ curl -XPUT 'localhost:9200/mydocs/' -d '{}'
{"ok":true,"acknowledged":true}

$ curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{
"type": "fs",
"fs": {
"url": "/tmp",
"update_rate": 900000,
"includes": ".doc,.pdf",
"excludes": "resume"
}
}'
{"ok":true,"_index":"_river","_type":"mydocs","_id":"_meta","_version":1}

$ curl localhost:9200/_river/mydocs/_stop
{"ok":true}

I tested it on ES 0.90.0.RC2 with this version: https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/fsriver-0.2.0-20130424.091836-2.zip
With mapper attachment 1.7.0

Please remove any fsriver plugin in /plugins. I suspect that you did not clean it well.

I run that test on an empty cluster.

I tested also:
$ curl 'localhost:9200/_river/mydocs/_stop'
{"ok":true}

$ curl 'localhost:9200/_river/mydocs/_stop?pretty'
{
"ok" : true
}

HTH

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 25 avr. 2013 à 12:08, Ajitpal Singh ajit.kamboj@gmail.com a écrit :

Thanks for clarification.

Actually i was trying to update the fsriver code before _start, _stop implementation. I just added the ManageriverAction class and update the run code in FSParser class to test something. But the _stop is still giving the old json that i have mentioned earlier, is i'm missing something?

Thanks

On Thursday, 25 April 2013 10:37:18 UTC+1, David Pilato wrote:
Yes. It only pause actually one single river instance.
The river is still running but does not try to fetch document anymore. The river only checks every x seconds if you restarted or not.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 25 avr. 2013 à 10:53, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Just a simple question, Does the river _stop the particular river only? Suppose if i have two river with localdoc1, localdoc2, when i call localdoc2/_stop in curl. then it will only stop the localdoc2 river only?

thanks :}

On Wednesday, 24 April 2013 16:17:54 UTC+1, David Pilato wrote:
Try to use the latest from here: https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/

This should work:

curl localhost:9200/_river/wikidocs/_stop

Just to make sure, can you do the following?

curl localhost:9200/_river/_search?q=*

I would like to check the river id.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 24 avr. 2013 à 16:55, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

No, i just imported the git project and compiled , then replaced the jar file to target jar file. may be mistake on my side, i just saw the new documentation about stop process and tried it :{

Well i have tried removing pretty from the get the same result.

Thanks

On Wednesday, 24 April 2013 15:44:48 UTC+1, David Pilato wrote:
Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which contain some files and pdf. it is running at interval of 2 min. When i call the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty
{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i tired to update the document and got the updated result after 2 min. Does _stop means that the river will stop the indexing the particular index or something else?

just to log the result, i run the following curl command to verify my results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty
{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" : {"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:
It's now added in FSRiver and will be part of 0.2.0 release: https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river run on the thread at particular interval for eg. 180000 [every 3 min]. Can we pause/stop the index, but still able to run search query? Using curl command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi,

i have check all these test yesterday & they were working perfectly.
It might be a crazy question, but just updating the FSParser code from
latest git version and adding new package to previous stable version of
fs-river is not working on my side.?
did i miss something anything else?

thanks

On Thursday, 25 April 2013 11:27:24 UTC+1, David Pilato wrote:

I checked:

$ curl -XPUT 'localhost:9200/mydocs/' -d '{}'
{"ok":true,"acknowledged":true}

$ curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{
"type": "fs",
"fs": {
"url": "/tmp",
"update_rate": 900000,
"includes": ".doc,.pdf",
"excludes": "resume"
}
}'
{"ok":true,"_index":"_river","_type":"mydocs","_id":"_meta","_version":1}

$ curl localhost:9200/_river/mydocs/_stop
{"ok":true}

I tested it on ES 0.90.0.RC2 with this version:
https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/fsriver-0.2.0-20130424.091836-2.zip
With mapper attachment 1.7.0

Please remove any fsriver plugin in /plugins. I suspect that you did not
clean it well.

I run that test on an empty cluster.

I tested also:
$ curl 'localhost:9200/_river/mydocs/_stop'
{"ok":true}

$ curl 'localhost:9200/_river/mydocs/_stop?pretty'
{
"ok" : true
}

HTH

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 25 avr. 2013 à 12:08, Ajitpal Singh <ajit....@gmail.com <javascript:>>
a écrit :

Thanks for clarification.

Actually i was trying to update the fsriver code before _start, _stop
implementation. I just added the ManageriverAction class and update the run
code in FSParser class to test something. But the _stop is still giving the
old json that i have mentioned earlier, is i'm missing something?

Thanks

On Thursday, 25 April 2013 10:37:18 UTC+1, David Pilato wrote:

Yes. It only pause actually one single river instance.
The river is still running but does not try to fetch document anymore.
The river only checks every x seconds if you restarted or not.

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 25 avr. 2013 à 10:53, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Just a simple question, Does the river _stop the particular river only?
Suppose if i have two river with localdoc1, localdoc2, when i call
localdoc2/_stop in curl. then it will only stop the localdoc2 river only?

thanks :}

On Wednesday, 24 April 2013 16:17:54 UTC+1, David Pilato wrote:

Try to use the latest from here:
https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/

This should work:

curl localhost:9200/_river/wikidocs/_stop

Just to make sure, can you do the following?

curl localhost:9200/_river/_search?q=*

I would like to check the river id.

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:55, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

No, i just imported the git project and compiled , then replaced the jar
file to target jar file. may be mistake on my side, i just saw the new
documentation about stop process and tried it :{

Well i have tried removing pretty from the get the same result.

Thanks

On Wednesday, 24 April 2013 15:44:48 UTC+1, David Pilato wrote:

Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your
package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which
contain some files and pdf. it is running at interval of 2 min. When i call
the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i
tired to update the document and got the updated result after 2 min. Does

  • _stop* means that the river will stop the indexing the particular
    index or something else?

just to log the result, i run the following curl command to verify my
results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" :
{"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/
172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:

It's now added in FSRiver and will be part of 0.2.0 release:
https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can
open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river
run on the thread at particular interval for eg. 180000 [every 3 min]. Can
we pause/stop the index, but still able to run search query? Using curl
command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we
open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hey,

Have a look at my commit.
I changed many other classes: https://github.com/dadoonet/fsriver/commit/1130e96f9141b351dbf14210bd110c00ae40e170

I added a REST endpoint… That's the reason it does not work on your side.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 25 avr. 2013 à 12:38, Ajitpal Singh ajit.kamboj@gmail.com a écrit :

Hi,

i have check all these test yesterday & they were working perfectly.
It might be a crazy question, but just updating the FSParser code from latest git version and adding new package to previous stable version of fs-river is not working on my side.?
did i miss something anything else?

thanks

On Thursday, 25 April 2013 11:27:24 UTC+1, David Pilato wrote:
I checked:

$ curl -XPUT 'localhost:9200/mydocs/' -d '{}'
{"ok":true,"acknowledged":true}

$ curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{
"type": "fs",
"fs": {
"url": "/tmp",
"update_rate": 900000,
"includes": ".doc,.pdf",
"excludes": "resume"
}
}'
{"ok":true,"_index":"_river","_type":"mydocs","_id":"_meta","_version":1}

$ curl localhost:9200/_river/mydocs/_stop
{"ok":true}

I tested it on ES 0.90.0.RC2 with this version: https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/fsriver-0.2.0-20130424.091836-2.zip
With mapper attachment 1.7.0

Please remove any fsriver plugin in /plugins. I suspect that you did not clean it well.

I run that test on an empty cluster.

I tested also:
$ curl 'localhost:9200/_river/mydocs/_stop'
{"ok":true}

$ curl 'localhost:9200/_river/mydocs/_stop?pretty'
{
"ok" : true
}

HTH

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 25 avr. 2013 à 12:08, Ajitpal Singh ajit....@gmail.com a écrit :

Thanks for clarification.

Actually i was trying to update the fsriver code before _start, _stop implementation. I just added the ManageriverAction class and update the run code in FSParser class to test something. But the _stop is still giving the old json that i have mentioned earlier, is i'm missing something?

Thanks

On Thursday, 25 April 2013 10:37:18 UTC+1, David Pilato wrote:
Yes. It only pause actually one single river instance.
The river is still running but does not try to fetch document anymore. The river only checks every x seconds if you restarted or not.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 25 avr. 2013 à 10:53, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Just a simple question, Does the river _stop the particular river only? Suppose if i have two river with localdoc1, localdoc2, when i call localdoc2/_stop in curl. then it will only stop the localdoc2 river only?

thanks :}

On Wednesday, 24 April 2013 16:17:54 UTC+1, David Pilato wrote:
Try to use the latest from here: https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/

This should work:

curl localhost:9200/_river/wikidocs/_stop

Just to make sure, can you do the following?

curl localhost:9200/_river/_search?q=*

I would like to check the river id.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 24 avr. 2013 à 16:55, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

No, i just imported the git project and compiled , then replaced the jar file to target jar file. may be mistake on my side, i just saw the new documentation about stop process and tried it :{

Well i have tried removing pretty from the get the same result.

Thanks

On Wednesday, 24 April 2013 15:44:48 UTC+1, David Pilato wrote:
Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which contain some files and pdf. it is running at interval of 2 min. When i call the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty
{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i tired to update the document and got the updated result after 2 min. Does _stop means that the river will stop the indexing the particular index or something else?

just to log the result, i run the following curl command to verify my results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty
{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" : {"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:
It's now added in FSRiver and will be part of 0.2.0 release: https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river run on the thread at particular interval for eg. 180000 [every 3 min]. Can we pause/stop the index, but still able to run search query? Using curl command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Dear David,

Few stupid questions for you.
I keep receiving empty result set on any search attempt. I used your
'mydocs' sample.
Is it possible to enable some logging to see what's wrong?

Also attempts to start/stop river interpreted as a regular index query:
$ curl localhost:9200/_river/mydocs/_stop
{"_index":"_river","_type":"mydocs","_id":"_stop","exists":false}

P.S. I tried v 0.0.2 and v0.0.3 of fsriver. I use elasticsearch v 0.90

Thank you.

On Thursday, April 25, 2013 4:51:59 AM UTC-7, David Pilato wrote:

Hey,

Have a look at my commit.
I changed many other classes:
https://github.com/dadoonet/fsriver/commit/1130e96f9141b351dbf14210bd110c00ae40e170

I added a REST endpoint… That's the reason it does not work on your side.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 25 avr. 2013 à 12:38, Ajitpal Singh <ajit....@gmail.com <javascript:>>
a écrit :

Hi,

i have check all these test yesterday & they were working perfectly.
It might be a crazy question, but just updating the FSParser code from
latest git version and adding new package to previous stable version of
fs-river is not working on my side.?
did i miss something anything else?

thanks

On Thursday, 25 April 2013 11:27:24 UTC+1, David Pilato wrote:

I checked:

$ curl -XPUT 'localhost:9200/mydocs/' -d '{}'
{"ok":true,"acknowledged":true}

$ curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{
"type": "fs",
"fs": {
"url": "/tmp",
"update_rate": 900000,
"includes": ".doc,.pdf",
"excludes": "resume"
}
}'
{"ok":true,"_index":"_river","_type":"mydocs","_id":"_meta","_version":1}

$ curl localhost:9200/_river/mydocs/_stop
{"ok":true}

I tested it on ES 0.90.0.RC2 with this version:
https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/fsriver-0.2.0-20130424.091836-2.zip
With mapper attachment 1.7.0

Please remove any fsriver plugin in /plugins. I suspect that you did not
clean it well.

I run that test on an empty cluster.

I tested also:
$ curl 'localhost:9200/_river/mydocs/_stop'
{"ok":true}

$ curl 'localhost:9200/_river/mydocs/_stop?pretty'
{
"ok" : true
}

HTH

David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 25 avr. 2013 à 12:08, Ajitpal Singh ajit....@gmail.com a écrit :

Thanks for clarification.

Actually i was trying to update the fsriver code before _start, _stop
implementation. I just added the ManageriverAction class and update the run
code in FSParser class to test something. But the _stop is still giving the
old json that i have mentioned earlier, is i'm missing something?

Thanks

On Thursday, 25 April 2013 10:37:18 UTC+1, David Pilato wrote:

Yes. It only pause actually one single river instance.
The river is still running but does not try to fetch document anymore.
The river only checks every x seconds if you restarted or not.

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 25 avr. 2013 à 10:53, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Just a simple question, Does the river _stop the particular river only?
Suppose if i have two river with localdoc1, localdoc2, when i call
localdoc2/_stop in curl. then it will only stop the localdoc2 river only?

thanks :}

On Wednesday, 24 April 2013 16:17:54 UTC+1, David Pilato wrote:

Try to use the latest from here:
https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/

This should work:

curl localhost:9200/_river/wikidocs/_stop

Just to make sure, can you do the following?

curl localhost:9200/_river/_search?q=*

I would like to check the river id.

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:55, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

No, i just imported the git project and compiled , then replaced the
jar file to target jar file. may be mistake on my side, i just saw the new
documentation about stop process and tried it :{

Well i have tried removing pretty from the get the same result.

Thanks

On Wednesday, 24 April 2013 15:44:48 UTC+1, David Pilato wrote:

Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your
package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which
contain some files and pdf. it is running at interval of 2 min. When i call
the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i
tired to update the document and got the updated result after 2 min. Does

  • _stop* means that the river will stop the indexing the particular
    index or something else?

just to log the result, i run the following curl command to verify my
results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" :
{"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/
172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:

It's now added in FSRiver and will be part of 0.2.0 release:
https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can
open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The
fs-river run on the thread at particular interval for eg. 180000 [every 3
min]. Can we pause/stop the index, but still able to run search query?
Using curl command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we
open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Try with version 0.2.0 not 0.0.2.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juin 2013 à 06:11, Sergey Romanovsky romanovsky@gmail.com a écrit :

Dear David,

Few stupid questions for you.
I keep receiving empty result set on any search attempt. I used your 'mydocs' sample.
Is it possible to enable some logging to see what's wrong?

Also attempts to start/stop river interpreted as a regular index query:
$ curl localhost:9200/_river/mydocs/_stop
{"_index":"_river","_type":"mydocs","_id":"_stop","exists":false}

P.S. I tried v 0.0.2 and v0.0.3 of fsriver. I use elasticsearch v 0.90

Thank you.

On Thursday, April 25, 2013 4:51:59 AM UTC-7, David Pilato wrote:

Hey,

Have a look at my commit.
I changed many other classes: https://github.com/dadoonet/fsriver/commit/1130e96f9141b351dbf14210bd110c00ae40e170

I added a REST endpoint… That's the reason it does not work on your side.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 25 avr. 2013 à 12:38, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

i have check all these test yesterday & they were working perfectly.
It might be a crazy question, but just updating the FSParser code from latest git version and adding new package to previous stable version of fs-river is not working on my side.?
did i miss something anything else?

thanks

On Thursday, 25 April 2013 11:27:24 UTC+1, David Pilato wrote:

I checked:

$ curl -XPUT 'localhost:9200/mydocs/' -d '{}'
{"ok":true,"acknowledged":true}

$ curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{
"type": "fs",
"fs": {
"url": "/tmp",
"update_rate": 900000,
"includes": ".doc,.pdf",
"excludes": "resume"
}
}'
{"ok":true,"_index":"_river","_type":"mydocs","_id":"_meta","_version":1}

$ curl localhost:9200/_river/mydocs/_stop
{"ok":true}

I tested it on ES 0.90.0.RC2 with this version: https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/fsriver-0.2.0-20130424.091836-2.zip
With mapper attachment 1.7.0

Please remove any fsriver plugin in /plugins. I suspect that you did not clean it well.

I run that test on an empty cluster.

I tested also:
$ curl 'localhost:9200/_river/mydocs/_stop'
{"ok":true}

$ curl 'localhost:9200/_river/mydocs/_stop?pretty'
{
"ok" : true
}

HTH

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 25 avr. 2013 à 12:08, Ajitpal Singh ajit....@gmail.com a écrit :

Thanks for clarification.

Actually i was trying to update the fsriver code before _start, _stop implementation. I just added the ManageriverAction class and update the run code in FSParser class to test something. But the _stop is still giving the old json that i have mentioned earlier, is i'm missing something?

Thanks

On Thursday, 25 April 2013 10:37:18 UTC+1, David Pilato wrote:

Yes. It only pause actually one single river instance.
The river is still running but does not try to fetch document anymore. The river only checks every x seconds if you restarted or not.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 25 avr. 2013 à 10:53, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Just a simple question, Does the river _stop the particular river only? Suppose if i have two river with localdoc1, localdoc2, when i call localdoc2/_stop in curl. then it will only stop the localdoc2 river only?

thanks :}

On Wednesday, 24 April 2013 16:17:54 UTC+1, David Pilato wrote:

Try to use the latest from here: https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/

This should work:

curl localhost:9200/_river/wikidocs/_stop

Just to make sure, can you do the following?

curl localhost:9200/_river/_search?q=*

I would like to check the river id.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 24 avr. 2013 à 16:55, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

No, i just imported the git project and compiled , then replaced the jar file to target jar file. may be mistake on my side, i just saw the new documentation about stop process and tried it :{

Well i have tried removing pretty from the get the same result.

Thanks

On Wednesday, 24 April 2013 15:44:48 UTC+1, David Pilato wrote:

Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which contain some files and pdf. it is running at interval of 2 min. When i call the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty
{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i tired to update the document and got the updated result after 2 min. Does _stop means that the river will stop the indexing the particular index or something else?

just to log the result, i run the following curl command to verify my results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty
{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" : {"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:

It's now added in FSRiver and will be part of 0.2.0 release: https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit :

Hi All,

I'm working with fs-river to index the local file system. The fs-river run on the thread at particular interval for eg. 180000 [every 3 min]. Can we pause/stop the index, but still able to run search query? Using curl command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

David,

0.2.0 works fine. Thanks for your help!

On Wednesday, June 5, 2013 10:11:14 PM UTC-7, David Pilato wrote:

Try with version 0.2.0 not 0.0.2.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juin 2013 à 06:11, Sergey Romanovsky <roman...@gmail.com<javascript:>>
a écrit :

Dear David,

Few stupid questions for you.
I keep receiving empty result set on any search attempt. I used your
'mydocs' sample.
Is it possible to enable some logging to see what's wrong?

Also attempts to start/stop river interpreted as a regular index query:
$ curl localhost:9200/_river/mydocs/_stop
{"_index":"_river","_type":"mydocs","_id":"_stop","exists":false}

P.S. I tried v 0.0.2 and v0.0.3 of fsriver. I use elasticsearch v 0.90

Thank you.

On Thursday, April 25, 2013 4:51:59 AM UTC-7, David Pilato wrote:

Hey,

Have a look at my commit.
I changed many other classes:
https://github.com/dadoonet/fsriver/commit/1130e96f9141b351dbf14210bd110c00ae40e170

I added a REST endpoint… That's the reason it does not work on your side.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 25 avr. 2013 à 12:38, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

i have check all these test yesterday & they were working perfectly.
It might be a crazy question, but just updating the FSParser code from
latest git version and adding new package to previous stable version of
fs-river is not working on my side.?
did i miss something anything else?

thanks

On Thursday, 25 April 2013 11:27:24 UTC+1, David Pilato wrote:

I checked:

$ curl -XPUT 'localhost:9200/mydocs/' -d '{}'
{"ok":true,"acknowledged":true}

$ curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{
"type": "fs",
"fs": {
"url": "/tmp",
"update_rate": 900000,
"includes": ".doc,.pdf",
"excludes": "resume"
}
}'
{"ok":true,"_index":"_river","_type":"mydocs","_id":"_meta","_version":1}

$ curl localhost:9200/_river/mydocs/_stop
{"ok":true}

I tested it on ES 0.90.0.RC2 with this version:
https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/fsriver-0.2.0-20130424.091836-2.zip
With mapper attachment 1.7.0

Please remove any fsriver plugin in /plugins. I suspect that you did not
clean it well.

I run that test on an empty cluster.

I tested also:
$ curl 'localhost:9200/_river/mydocs/_stop'
{"ok":true}

$ curl 'localhost:9200/_river/mydocs/_stop?pretty'
{
"ok" : true
}

HTH

David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 25 avr. 2013 à 12:08, Ajitpal Singh ajit....@gmail.com a écrit :

Thanks for clarification.

Actually i was trying to update the fsriver code before _start, _stop
implementation. I just added the ManageriverAction class and update the run
code in FSParser class to test something. But the _stop is still giving the
old json that i have mentioned earlier, is i'm missing something?

Thanks

On Thursday, 25 April 2013 10:37:18 UTC+1, David Pilato wrote:

Yes. It only pause actually one single river instance.
The river is still running but does not try to fetch document anymore.
The river only checks every x seconds if you restarted or not.

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 25 avr. 2013 à 10:53, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Just a simple question, Does the river _stop the particular river
only? Suppose if i have two river with localdoc1, localdoc2, when i call
localdoc2/_stop in curl. then it will only stop the localdoc2 river only?

thanks :}

On Wednesday, 24 April 2013 16:17:54 UTC+1, David Pilato wrote:

Try to use the latest from here:
https://oss.sonatype.org/content/repositories/snapshots/fr/pilato/elasticsearch/river/fsriver/0.2.0-SNAPSHOT/

This should work:

curl localhost:9200/_river/wikidocs/_stop

Just to make sure, can you do the following?

curl localhost:9200/_river/_search?q=*

I would like to check the river id.

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:55, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

No, i just imported the git project and compiled , then replaced the
jar file to target jar file. may be mistake on my side, i just saw the new
documentation about stop process and tried it :{

Well i have tried removing pretty from the get the same result.

Thanks

On Wednesday, 24 April 2013 15:44:48 UTC+1, David Pilato wrote:

Hmmm. Sounds like I should support POST for this method.

That said, may be a stupid question, did you create yourself your
package?
I mean that I did not release yet this new version.

Also, just remove the ?pretty at the end and see if it's better.

Answer you should get from FSRiver is only a { "ok" : true }

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 24 avr. 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

Thanks for adding the code in ManageRiverAction. :}

Actually, I have a local river running with name of wikidocs which
contain some files and pdf. it is running at interval of 2 min. When i call
the command

curl '172.16.51.128:9200/_river/wikidocs/_stop'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_stop",
"exists" : false
}

the log show the river is still indexing the content in folder and i
tired to update the document and got the updated result after 2 min. Does

  • _stop* means that the river will stop the indexing the particular
    index or something else?

just to log the result, i run the following curl command to verify my
results

curl '172.16.51.128:9200/_river/wikidocs/_status'?pretty

{
"_index" : "_river",
"_type" : "wikidocs",
"_id" : "_status",
"_version" : 1,
"exists" : true, "_source" :
{"ok":true,"node":{"id":"qttVufn6QRyUN5bd7AgejQ","name":"Elastic-Master","transport_address":"inet[/
172.16.51.128:9300]"}}

Thanks
Ajitpal Singh

On Tuesday, 23 April 2013 23:17:38 UTC+1, David Pilato wrote:

It's now added in FSRiver and will be part of 0.2.0 release:
https://github.com/dadoonet/fsriver/issues/21

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 12:30, David Pilato da...@pilato.fr a écrit :

You can close the _river index.
Note that it will suspend all rivers.

That said, if you need to have an action to suspend FSRiver, you can
open an issue in FSRiver project and I will try to add it.

HTH

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2013 à 11:13, Ajitpal Singh ajit....@gmail.com a écrit
:

Hi All,

I'm working with fs-river to index the local file system. The
fs-river run on the thread at particular interval for eg. 180000 [every 3
min]. Can we pause/stop the index, but still able to run search query?
Using curl command

curl -XPOST "localhost:9200/my_index/_close/"

will close the index, but the search capability also stops, Until we
open the index again using _open switch.

thanks,
Ajitpal

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.