FSCrawler 2.9 -supported versions of Elastic

We are using FSCrawler 2.7 with Elastics 7.10.2.

Does the new version of FSCrawler 2.9 support Elastics 7.10.2 or do we have to upgrade to 7.16.2?

If you are using 7.10.2 with the default distribution, it should work.
I think that it might not work with 7.10.2 OSS distribution.

But anyway, you should really upgrade your Elasticsearch cluster.

Thanks we are on the licenced version.

So this should work well. But as I said, you should upgrade anyway.