Functionbeat ignores default region - only deploys to us-east-1 (AWS)

Hey,

Trying to deploy the latest Functionbeat version (7.13.x), and it appears that Functionbeat is ignoring the AWS_DEFAULT_REGION environment variable when deploying - it always deploys to North Virginia (us-east-1) instead. The docs (Functionbeat quick start: installation and configuration | Functionbeat Reference [7.13] | Elastic) state that this should be overridable with the AWS_DEFAULT_REGION environment variable, as with other AWS tools.

It can be observed that this occurs by the fact that the deployment fails due to being unable to find the log stream I am trying to trigger on (as it is in Ireland) - on debugging it appears both the S3 bucket and CloudFormation stack are both deployed in us-east-1 instead of eu-west-1 despite the environment variable being set correctly.

Env output:

$ env
(...)
AWS_DEFAULT_REGION=eu-west-1
AWS_ACCESS_KEY_ID=xxx
AWS_SECRET_ACCESS_KEY=xxx
AWS_SESSION_TOKEN=xxx

Functionbeat deploy log too long for post - pastebin link: Functionbeat deploy log - Pastebin.com

Also worth noting that this process worked fine in the previous Functionbeat version (7.12.x) - it appears to have been introduced in 7.13.x.

Does anyone have any ideas?

2 Likes

I am experiencing the same issue on 7.13.2 where Functionbeat ignores the default region (ap-southeast-1) set in environment variables and deploys it to us-east-1.

Works fine on 7.12.1.

Same issue here, I reverted to 7.12.1

I raised the issue Functionbeat ignores default region - only deploys to us-east-1 (AWS) · Issue #26497 · elastic/beats · GitHub

Same error on 7.13.3

The PR to resolve the issue hasn't been merged yet. Expose region in AWS configuration so Functionbeat can deploy the Lamba in the correct place by kvch · Pull Request #26523 · elastic/beats · GitHub