Gem::LoadError activated jar-dependencies


(Milad Hamid) #1

Hi,

I installed logstash 6.1 and when running logstash and pipeline, getting following error message:

Gem::LoadError: You have already activated jar-dependencies 0.3.12, but your Gemfile
requires jar-dependencies 0.3.11. Prepending `bundle exec` to your command may solve this.

block in setup at /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/bundler-1.9.10/lib/bundler/runtime.rb:34 

My logstash pipeline:

input {
  file {
    path => "/var/log/apache2/access.log"
    start_position => "beginning"
  }
}

filter {
  if [path] =~ "access" {
    mutate { replace => { "type" => "apache_access" } }
    grok {
      match => { "message" => "%{COMBINEDAPACHELOG}" }
    }
  }
  date {
    match => [ "timestamp" , "dd/MMM/yyyy:HH:mm:ss Z" ]
  }
}

output {
  elasticsearch {
    hosts => ["localhost:9200"]
  }
  stdout { codec => rubydebug }
}

Please help with this issue.


(Milad Hamid) #2

Please if anyone can help with this!


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.