Logstash-plugin list display Gem errors


(Samuel Mutel) #1

Hello,

When I execute the command "/usr/share/logstash/bin/logstash-plugin list", I have the error below:

Gem::LoadError: You have already activated json 1.8.6, but your Gemfile requires json 1.8.3. Prepending bundle exec to your command may solve this.
setup at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/runtime.rb:34
each at org/jruby/RubyArray.java:1613
each at /usr/share/logstash/vendor/jruby/lib/ruby/1.9/forwardable.rb:201
setup at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/runtime.rb:19
setup at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler.rb:122
setup! at /usr/share/logstash/lib/bootstrap/bundler.rb:64
execute at /usr/share/logstash/lib/pluginmanager/list.rb:17
run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
execute at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/subcommand/execution.rb:11
run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132
(root) at /usr/share/logstash/lib/pluginmanager/main.rb:44

I am sure that I did something wrong but what thing?


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.