Logstash 5.2 logstash-plugin fails with jar dependencies


(Cliff Sobchuk) #1

Hi I am using Logstash 5.2 on Ubuntu 14.04 and have been trying to list/install/update plugins, but I get the following error for any action.

     sudo bin/logstash-plugin list
Gem::LoadError: You have already activated jar-dependencies 0.3.10, but your Gemfile requires jar-dependencies 0.3.9. Prepending `bundle exec` to your command may solve this.
    setup at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/runtime.rb:34
     each at org/jruby/RubyArray.java:1613
     each at /usr/share/logstash/vendor/jruby/lib/ruby/1.9/forwardable.rb:201
    setup at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/runtime.rb:19
    setup at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler.rb:122
   setup! at /usr/share/logstash/lib/bootstrap/bundler.rb:64
  execute at /usr/share/logstash/lib/pluginmanager/list.rb:17
      run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
  execute at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/subcommand/execution.rb:11
      run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
      run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132
   (root) at /usr/share/logstash/lib/pluginmanager/main.rb:46

Thanks, Cliff.


(Cliff Sobchuk) #2

sudo apt-get remove logstash and then install logstash corrected the issue.


(Cliff Sobchuk) #3

This problem is back again. Seemingly no reason as nothing had changed but today there is no plugin list/install/update.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.