Generate Plugin not working on 6.4.2


I am trying to create a custom plugin on Red Hat Linux Enterprise 7 using plugin generator script packaged with kibana 6.4.2 but it fails with following errors -

error Couldn't find package "debug@^2.6.6" required by "@elastic/eslint-import-resolver-kibana@link:../../kibana/packages/kbn-eslint-import-resolver-kibana" on the "npm" registry.
info Visit for documentation about this command.
Error: Couldn't find package "eslint-import-resolver-node@^0.3.0" required by "@elastic/eslint-import-resolver-kibana@link:../../kibana/packages/kbn-eslint-import-resolver-kibana" on the "npm" registry.

Error: Couldn't find package "glob-all@^3.1.0" required by "@elastic/eslint-import-resolver-kibana@link:../../kibana/packages/kbn-eslint-import-resolver-kibana" on the "npm" registry.

Error: Couldn't find package "resolve@^1.7.1" required by "@elastic/eslint-import-resolver-kibana@link:../../kibana/packages/kbn-eslint-import-resolver-kibana" on the "npm" registry.

Error: Couldn't find package "webpack@3.6.0" required by "@elastic/eslint-import-resolver-kibana@link:../../kibana/packages/kbn-eslint-import-resolver-kibana" on the "npm" registry.

Error: Command failed: yarn kbn bootstrap


Does it work with another version? If so, please file a bug report here with all the pertinent details and exact steps. If doing so, it's worth adding the issue link here as well.

I can't try on other versions since by elastic server is on 6.4.2 and I have to use same kibana version. Will be opening a bug report. Basically what I find is that the yarn kbn bootstrap is not able to identify/resolve the dependencies from node_modules of "eslint-import-resolver-kibana".


It might be worth trying yarn kbn clean before yarn kbn bootstrap, or a fresh setup. But it could be a registry issue as well, please check if maybe it's pointing to a local registry.

I have tried yarn kbn clean and bootstrap several times but it doesn't help. Also you mentioned that it be an issue with local registry, what exactly did you mean? Could you please clarify a bit on this? Also I'll try this on Kibana 6.5 and let you know the outcome.Have opened an issue with git -


The issue is not occuring in the latest version, the root cause is use of "link" in package.json. In the latest kibana source code the package.json doesn't have any link and so when the custom kibana is getting bootstrapped all the dependencies are downloaded and referred from it's local node_modules, which is not true for 6.4.2 where it is trying to resolve the dependencies from local package and hence the bootstrap is failing.


Any help on this?

Thanks, we received your ticket.

By registry I meant the possibility of local module registry - if you use local registry and that pertains to the issue, or you come across any other detail that's specific to your setup, please update the github issue you created.

No I haven't used any local registry.

I have tried the same steps on Ubuntu 16.04.3 LTS and the generator plugin is working and creating the plugin folder but yarn start crashes with error - Error: self signed certificate in certificate chain on both Ubuntu and Oracle Linux servers. So forced to start the plugin using yarn start -oss

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.