Getting 403 after ECK installation on Openshift

I am following the instructions from this page. I tried logging into Kibana using the username/password in the secret: kibana-sample-kibana-user. Once I log in, I get a 403 and I do not know how to proceed from here. Please provide some guidance!

Hi @Vijay_Bhaskar_Chinta,

Welcome to our community! For getting access to ECK you also have to decode the password, did you try this?

See also the quickstart on how to get password:

For example:
PASSWORD=$(kubectl get secret quickstart-es-elastic-user -o=jsonpath='{.data.elastic}' | base64 --decode)

Hope this help, thanks!

Thanks Liza, I see the credentials for elastic in the secret: elasticsearch-sample-es-elastic-user. I used it to log into Kibana and it worked for me. If I should be using anything else please let me know.

Many thanks again!

1 Like

Glad it worked @Vijay_Bhaskar_Chinta! So elastic is a super user and depending on what you are trying to do you may want to create other users/roles with certain permissions in Kibana, see:

Hope this helps,


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.