Getting issue while installing kibana

HI Team,

-I am getting issue while installing kibana on dev mode.
Kibana Version - 7.14.0
Node Version - 14.17.3

-I am using the following URL for installation process.

-I am cloning the code using the below URL

-"yarn install" is successful but when I run "yarn kbn bootstrap", I am getting following error

"/6nw4ondz/external/npm/typescript/bin/BUILD.bazel:9:14: Creating runfiles tree bazel-out/host/bin/external/npm/typescript/bin/tsc.bat.runfiles [for host] failed: build-runfiles.exe failed: error executing command"

/kibana/packages/elastic-eslint-config-kibana/BUILD.bazel:44:8 Assembling npm package packages/elastic-eslint-config-kibana/npm_module failed: build-runfiles.exe failed: error executing command

-I tried running command "yarn start" but got the following error:

yarn start
yarn run v1.22.11
$ node scripts/kibana --dev
  throw err;
Error: Cannot find module '@kbn/apm-config-loader'

Now I tried with adding yarn add kbn/apm-config-loader but landed up with error again

error Command failed.
Exit code: 128
Command: git
Arguments: ls-remote --tags --heads ssh://
Directory: D:\kibana
Output: Permission denied (publickey).
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.

Can anyone help me out with this.

Hello, is developer mode activated on your computer? Enable your device for development - Windows apps | Microsoft Docs Please see it as one of the steps here Getting started | Kibana Guide [7.14] | Elastic

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.