Getting Kibana Error: Please ensure that Elasticsearch is reachable from your system


(info) #1

I have the following setup:

Application Server with NGINX and Kibana and configured as reverse proxy
Two node Elasticsearch cluster
Both hosted on EC2

When I try to query Elasticsearch through Kibana from behind a corporate
firewall I get the following error message:

"Could not contact Elasticsearch at http://IP:9200 Please ensure that
Elasticsearch is reachable from your system.. "

I presume that the issue is down to port 9200 being closed in the firewall.

Are there any solutions to this (without changing the firewall settings or
putting ES on port 8080 or similar)

Thanks a lot
uli

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/666d39f7-9506-4e2b-9550-ad4f7d144bf0%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Tony Su) #2

Without changing a firewall setting on the IP address you're trying to
connect to? Or changing to a port that is already open?

IMO it has to be open, there is no alternative. Someone may opine
differently, but from what I've seen Kibana does not support a transport
other than IP (like pipes).
If you have ES running on the local node, then you can open the port on the
local machine.

IMO,
TSU

On Friday, February 7, 2014 6:24:26 AM UTC-8, in...@bi-q.ie wrote:

I have the following setup:

Application Server with NGINX and Kibana and configured as reverse proxy
Two node Elasticsearch cluster
Both hosted on EC2

When I try to query Elasticsearch through Kibana from behind a corporate
firewall I get the following error message:

"Could not contact Elasticsearch at http://IP:9200 Please ensure that
Elasticsearch is reachable from your system.. "

I presume that the issue is down to port 9200 being closed in the firewall.

Are there any solutions to this (without changing the firewall settings or
putting ES on port 8080 or similar)

Thanks a lot
uli

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/35c6a2b8-850a-43ab-a274-95417b879a11%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Walkom) #3

It'd probably depend on your nginx setup. If you can gist it it'd help.

We use a reverse proxy so the users browser doesn't do a direct connect to
ES, and this works fine.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 8 February 2014 02:36, Tony Su tonysu999@gmail.com wrote:

Without changing a firewall setting on the IP address you're trying to
connect to? Or changing to a port that is already open?

IMO it has to be open, there is no alternative. Someone may opine
differently, but from what I've seen Kibana does not support a transport
other than IP (like pipes).
If you have ES running on the local node, then you can open the port on
the local machine.

IMO,
TSU

On Friday, February 7, 2014 6:24:26 AM UTC-8, in...@bi-q.ie wrote:

I have the following setup:

Application Server with NGINX and Kibana and configured as reverse proxy
Two node Elasticsearch cluster
Both hosted on EC2

When I try to query Elasticsearch through Kibana from behind a corporate
firewall I get the following error message:

"Could not contact Elasticsearch at http://IP:9200 Please ensure that
Elasticsearch is reachable from your system.. "

I presume that the issue is down to port 9200 being closed in the
firewall.

Are there any solutions to this (without changing the firewall settings
or putting ES on port 8080 or similar)

Thanks a lot
uli

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/35c6a2b8-850a-43ab-a274-95417b879a11%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624ZVQtdqiQU58YP2qo1nU%2B0qZJ2p-EiETN%2BxtUgvGzQpTQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4