Graph Plugin Missing on Kibana 5


(Mitchell Waldman) #1

Hello!

I installed Kibana 5.0 and ES 5.0, and I'm able to bring up the Kibana UI, but I noticed that the graph app isn't listed on the side panel with all the other apps. I installed x-pack into Kibana and ES. Do I have to install something else to get the graph plugin displayed? Thanks!

Cheers,
Mitch


(Shaunak Kashyap) #2

Everything you did sounds correct. A few questions, to help figure out what's going on:

  1. What specific version of Elasticearch and Kibana did you install?

  2. When you start up the Kibana server for the very first time after installation, you should see a log line that looks something like this:

    optmzr log [15:57:23.526] [info][optimize] Lazy optimization of bundles for...

    Could you paste that complete line here?

  3. Are you seeing any errors in the Kibana server log either upon server startup or when you open Kibana in the browser?


(Mitchell Waldman) #3
  1. I'm using ES and Kibana 5.0.0-alpha3.
  2. I'm running a Docker compose with the Kibana 5.0.0-alpha3 image, and when it starts up I don't see any line like the one you posted. However, I do see it's posting the individual status for each plugin, and I got this for graph:
    kibana_1 | {"type":"log","@timestamp":"2016-06-28T22:55:00+00:00","tags":["status","plugin:graph","info"],"pid":8,"name":"plugin:graph","state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
  3. No, there are no errors.

(Shaunak Kashyap) #4

Don't worry about the line I asked about — it only shows up the very first time you start up a Kibana server and I'm not sure if that's even true for the Docker image.

The fact that you see the graph plugin going green is a good sign. It means the plugin code is present and the plugin initialization has succeeded.

I just installed ES + KB 5.0.0-alpha3 with the x-pack plugin in each and loaded up Kibana. I see the Graph application icon in the left nav like so:

What does your left nav look like?

Also, do you see any errors in your browser's developer console?


(Mitchell Waldman) #5

Here's my nav bar with an error in the console, although I believe that error is only because Kibana can't find an index.

I also put into my elasticsearch.yml and kibana.yml settings:
xpack.security.enabled: false
xpack.graph.enabled: true

Not sure if that info helps, but maybe. Thanks again for helping out!


(Shaunak Kashyap) #6

Ah, I was able to reproduce this issue. 5.0.0-alpha3 introduced a bug where Elasticsearch needed to fully start up before Kibana could be started up. This bug has been fixed in 5.0.0-alpha4 (which is coming out soon). Until then, here's the workaround (which may be tricky to pull off in a Docker compose setup):

  1. Start up Elasticsearch and wait till it is listening on its HTTP port (default: 9200).
  2. Start up Kibana.

(Mitchell Waldman) #7

Neato! I found my first bug! Haha okay, I'll try and give it a shot. I've been able to get around a fair amount of road bumps in getting this stack working. I think I might be able to fix this too. Thanks!


(Shaunak Kashyap) #8

Cool. Glad to help!

Moving this to the x-pack category as this turned out to be about an x-pack bug.


(Mitchell Waldman) #9

Fixed the issue. I copied the docker entrypoint shell script from the elastic docker repo, and added this line at the beginning of the script:
while [ $(curl -s -o /dev/null -w "%{http_code}" $ELASTIC_URL) != 200 ]; do echo "Waiting for elasticsearch to be ready before starting Kibana"; sleep 5; done

And now I see the graph plugin on the sidebar in Kibana!


(Shaunak Kashyap) #10

Great! Once the 5.0.0-alpha4 release of the stack is out you should be able to remove that line.


(system) #11