Graylog2 & ElsaticSearch connection problem

Hi.

I'm absolutely new with Graylog2 - so sorry if anything wrong.

After I installed it with thathttp://support.torch.sh/help/kb/graylog2-server/installing-graylog2-server-on-debian-6and
that http://bezha.od.ua/centos-6-2-x64-graylog2-v0-9-6/ instructions - I
got error when start it:

$ 2013-03-29 15:09:49,654 WARN : org.elasticsearch.discovery -
[graylog2-server] waited for 30s and no initial state was set by the
discovery
Exception in thread "main"
org.elasticsearch.discovery.MasterNotDiscoveredException: waited for [30s]

Full debug-log available herehttp://rtfm.co.ua/uploads/graylogstart-debug.txt
.

Used:

lsb_release -a

Description: Debian GNU/Linux 6.0.7 (squeeze)

Package: elasticsearch
Version: 0.20.6

Graylog2-server:

0.10.0-rc.1

Am I right understand that Graylog2-server cann't connect to *
ElasticSearch*?

Can somebody please give any idea to fix it?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Mar 29, 2013, at 3:50 PM, setevoй_червь™ setevoy4@gmail.com wrote:

Am I right understand that Graylog2-server cann't connect to ElasticSearch?

yes

Can somebody please give any idea to fix it?

it looks like you are trying to use multicast discovery.
check that your elastic search cluster is up and try to disable multicast discovery and use unicast discovery in elasticsearch.yml (the one used in graylog2-server, not the one in elasticsearch itself).

you can find the options here:
http://www.elasticsearch.org/guide/reference/modules/discovery/zen/

cheers,
-k

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Mar 29, 2013, at 3:50 PM, setevoй_червь™ setevoy4@gmail.com wrote:

Full debug-log available here.

oh, and you really want to update your graylog2 version. 0.10rc1 is old.

:slight_smile:

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

it looks like you are trying to use multicast discovery.

check that your elastic search cluster is up and try to disable multicast
discovery and use unicast discovery in elasticsearch.yml (the one used in
graylog2-server, not the one in elasticsearch itself).

On 03/29/2013 04:53 PM, Kay Röpke wrote:

it looks like you are trying to use multicast discovery.
check that your elastic search cluster is up and try to disable multicast
discovery and use unicast discovery in elasticsearch.yml (the one used in
graylog2-server, not the one in elasticsearch itself).

Thank for replay.

So I uncomment:

discovery.zen.ping.multicast.enabled: false

and:

discovery.zen.ping.unicast.hosts

And after that restarted Elastic.

But still have errors:

java -jar graylog2-server.jar --debug >

/home/setevoy/graylogstart-debug2.txt
Exception in thread "main"
org.elasticsearch.discovery.MasterNotDiscoveredException: waited for [30s]
at
org.elasticsearch.action.support.master.TransportMasterNodeOperationAction$3.onTimeout(TransportMasterNodeOperationAction.java:169)
at
org.elasticsearch.cluster.service.InternalClusterService$NotifyTimeout.run(InternalClusterService.java:356)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)

My configs:

graylog2.conf http://rtfm.co.ua/uploads/graylog2.conf
graylog2-elasticsearch.ymlhttp://rtfm.co.ua/uploads/graylog2-elasticsearch.yml

New debug-log available herehttp://rtfm.co.ua/uploads/graylogstart-debug2.txt
.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Friday, March 29, 2013 4:54:27 PM UTC+2, Kay Röpke wrote:

oh, and you really want to update your graylog2 version. 0.10rc1 is old.

It's last version I found on GitHubhttps://github.com/Graylog2/graylog2-server/downloads:slight_smile:

Can you please give any other source?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Mar 29, 2013, at 4:18 PM, setevoй_червь™ setevoy4@gmail.com wrote:

Can you please give any other source?

github has deprecated the uploads, so we can't upload binaries there anymore.
I guess the read me should mention that explicitly.
Get the latest from http://www.graylog2.org/download always :slight_smile:

As for your discovery:
you put 127.0.0.1:9350 into your discovery list.
But that's the address of the graylog2-server elastic search node, which it uses as a client to connect to the cluster.
You have to put in the address of the elastic search cluster you are running :wink:

cheers,
-k

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

29.03.2013 17:33, Kay Röpke пишет:

As for your discovery:
you put 127.0.0.1:9350 into your discovery list.
But that's the address of the graylog2-server elastic search node, which it uses as a client to connect to the cluster.
You have to put in the address of the elastic search cluster you are running :wink:

Kay, thanks - but I'll check it later on. Anyone sometimes must have
weekend :wink:

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Well, I'm finished my misfortune :slight_smile:

A lot of thanks to you and thathttps://groups.google.com/forum/?hl=en-US&fromgroups=#!topic/graylog2/3l8w9dx_wvUpost.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.