Help! I want to use high level client with weblogic, but deployment is failed

These are weblogic’s error logs.
I deployed the same application on tomcat, and it ran successfully. I has played with this error for almost a week. I can’t wait to kill this bug! Please help me!


Please don't post images of text as they are hardly readable and not searchable.

Instead paste the text and format it with </> icon. Check the preview window.

I can't tell about what is happening because in the stacktrace you pasted there is not a single line referencing elasticsearch code.
A wild guess is that something that elasticsearch client is adding (a JAR) is conflicting with Weblo. Jackson? HTTP layer? Other? I can't really tell.
What you can try is to simply remove the HLClient dependency and deploy again. If you have the same problem, then that's not coming from ES dep.
If you do have the same problem, just try to add the low level client for now and see if this is conflicting.

Thanks for your reply!
I had tried to remove some of the jars. I found out two jar is the conflict preventing the deployment.
They are
elasticsearch-core7.1.1.jar & log4j-api.jar(I forget the version).

My application can be deployed successfully without that two jars, but failed with any one of them. Of course, I can’t use ES without them.

Would you please deploy a demo to weblogic? Then you could decide whether to deal with it or to suggest me to replace weblogic.


I'm afraid I can't.
But if you'd like to replace Weblo by anything else, just try.

That said, did you try with the Low Level client only?

I think low level may be OK, but I must rewrite my code based on high level.:joy:

Thanks anyway!

I did not mean that you must rewrite. I just wanted to check it.
There might be another solution which consists of shading the conflicting dependencies. And I just believe that the logging one might be the problem here.

Could you try to shade it? I think I saw somewhere that we are going to shade some libs in the near future as well. (Didn't check that so I'm unsure)

As I say, I had tried without
And deployment is OK.
So I think if I just use low level api, it would be OK, of course.
But if I try, it need time. If I would have tried, I will tell you the result here.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.