Help - I've hosed my cygwin and can't run ES anymore


(James) #1

I've installed more packages and now, when I run bin/elasticsearch I now get this:

-bash-4.3$ cd elasticsearch-2.1.0/
-bash-4.3$ bin/elasticsearch
bin/elasticsearch: line 75: dirname: command not found
bin/elasticsearch: line 84: dirname: command not found
bin/elasticsearch: line 125: uname: command not found
bin/elasticsearch: line 134: cut: command not found
bin/elasticsearch: line 138: grep: command not found
Error: Could not find or load main class org.elasticsearch.bootstrap.Elasticsear       ch
-bash-4.3$

I've set the ES_CLASSPATH var on my machine to:
ES_CLASSPATH='C:\elasticsearch-2.1.0\bin' and set the Path variable to include it too. Still get startup errors.

Please help me restore the operation in this shell.


(Nik Everett) #2

Try running bin/elasticsearch.bat directly. It looks like your cygwin environment is missing too many linux things for bin/elasticsearch to work properly.


(James) #3

You were absolutely right - ES does start with bin/elasticsearch.bat and that is the important thing.

Moreover, you've made me realize that I have only a portion of what I've had before in cygwin.

Thx -


(James) #4

For the benefit of others... I discovered that somehow I've lost CYGWIN_HOME settings.

I've added CYGWIN_HOME = C:\userprograms\cygwin, and also I've added C:\userprograms\cygwin\bin; to my Path variable.

Restarted the cygwin window and got everything back again. Thx -


(system) #5