HELP! Kibana Error Connecting to ES on Docker - Cannot Revive Connection

Hello,
I keep on getting the following error

{"type":"log","@timestamp":"2019-08-08T02:52:45Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"No living connections"}
{"type":"log","@timestamp":"2019-08-08T02:52:45Z","tags":["warning","task_manager"],"pid":1,"message":"PollError No Living connections"}
{"type":"log","@timestamp":"2019-08-08T02:52:46Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"Unable to revive connection: http://192.168.86.2:9200/"}
{"type":"log","@timestamp":"2019-08-08T02:52:46Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"No living connections"}
{"type":"log","@timestamp":"2019-08-08T02:52:48Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"Unable to revive connection: http://192.168.86.2:9200/"}
{"type":"log","@timestamp":"2019-08-08T02:52:48Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"No living connections"}

kibana.yml file

xpack.infra.enabled: true
xpack.logstash.enabled: true
xpack.canvas.enabled: true
xpack.spaces.enabled: true
xpack.apm.enabled: true
xpack.security.enabled: true
xpack.reporting.enabled: true
xpack.ml.enabled: true
server.port: 5601
server.host: "0.0.0.0"
elasticsearch.hosts: ["http://192.168.86.2:9200"]

version: '2.3'
services:
#### ELK
## Elasticsearch service
  elasticsearch:
    container_name: elasticsearch
    restart: always
    environment:
     - bootstrap.memory_lock=true
     - "ES_JAVA_OPTS=-Xms2g -Xmx2g"
     - ES_TMPDIR=/tmp
    cap_add:
     - IPC_LOCK
    ulimits:
      memlock:
        soft: -1
        hard: -1
      nofile:
        soft: 65536
        hard: 65536
    mem_limit: 6g
    ports:
     - "127.0.0.1:64298:9200"
    image: "iukea/develasticsearch:4"
    volumes:
     - /data:/data

## Kibana service
  kibana:
    container_name: kibana
    restart: always
    network_mode: "host"
    ports:
     - "127.0.0.1:64296:5601"
    image: "iukea/devkibana:11"

## Logstash service
  logstash:
    container_name: logstash
    restart: always
    env_file:
     - /opt/ThreatSpy/etc/compose/elk_environment
    image: "iukea/logstash:4019"
    volumes:
     - /data:/data
    ports:
     - "6990:6990"

## Elasticsearch-head service
  head:
    container_name: head
    restart: always
    ports:
     - "127.0.0.1:64302:9100"
    image: "dtagdevsec/head:1811"
    read_only: false

any advice?

well i am a dummy

elasticsearch.hosts: ["http://127.0.0.1:64298"]

did the trick lol

@iukea you also have a strange configuration here:

ports:
     - "127.0.0.1:64298:9200"

I'll mark this as solved

1 Like