Hiding Minor Gridlines

I cannot seem to get the minor grid lines to go away when dealing with smaller numbers. I remember using earlier versions of Kibana that had an option to view minor gridlines, but cannot find it on 6.2.

In this example, the maximum hit for this particular item is 2:

So many extra gridlines and 0.5 ticks. Can I get them to go away?



Can you please tell me which visualization is this?


Hey there, This is a segment from the Vertical Bar Graph.


This is on 6.2.3 and I can hide the display of grid lines. Its under panel settings.

Does that help?



Thanks, but not quite. I can hide all grid lines or show the ones Kibana seems to want to display. What I want to do is show the relevant grid lines like whole numbers for instance. In my example above, it's showing some strange grid lines and in increments that do not line up with the odd counts, like 0.5 for example. So, I would like all the half counts to go away and only show grid lines where it would make sense, like at intervals of 1 in this case.

Ah..ok. @thomasneirynck can we get some help here please?


hi @motts,

what version of Kibana did you used to have this option?

This is not a setting in Kibana right now, like @bhavyarm mentioned, you can turn on/off gridlines altogether, but there is no setting to only show whole numbers.

It sounds like a feature request, so feel free to log here:https://github.com/elastic/kibana/issues/new

I am using 6.2. I will put in that request. The grid lines work well enough when using large numbers like 100+, but when you start working with smaller numbers, the increments and gridlines, I feel, start to misrepresent the data.

I will put in a request at the link. Thank you :smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.