Highlighting doesn't work on numeric and date fields


(Preeti Jain) #1

Hi All,

We are using elasticsearch version .90.03. We observed that highlighting
doesn't work on numeric and date fields.
Has someone else faced the same issue? What is the solution to this problem.

Thanks,
Preeti

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4d28d763-dde6-4440-a929-dca6a7541bd0%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Binh Ly) #2

You can do a multi-field on numeric fields with a string/not_analyzed field
and then highlight on that.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0f620002-0b84-4ec7-979b-8ab30f8fbbee%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Preeti Jain) #3

Thanks for your response.
I have to use numeric and date fields in range queries so the string field
of mutli-field will not work.
Any other thought?

On Friday, February 21, 2014 6:44:09 PM UTC+5:30, Binh Ly wrote:

You can do a multi-field on numeric fields with a string/not_analyzed
field and then highlight on that.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/349bc1ca-12bf-4f1c-a95f-785e0b245217%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Vineet Saju) #4

Any luck with this? I'm facing the same problem

On Monday, February 24, 2014 at 9:45:47 PM UTC-6, Preeti Jain wrote:

Thanks for your response.
I have to use numeric and date fields in range queries so the string field
of mutli-field will not work.
Any other thought?

On Friday, February 21, 2014 6:44:09 PM UTC+5:30, Binh Ly wrote:

You can do a multi-field on numeric fields with a string/not_analyzed
field and then highlight on that.

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e3d3921c-ac5c-4b74-89ac-516d213b5430%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #5