How can I bind my elb to Elasticsearch cluster on ECE


I created an elb in front of my ECE cluster. So I can use url to access like this.
http:// [ELB_DNS] :12400/#/region/ece-region/allocators

Therefore, I replace the IP in the cluster endpoint

But I can't access my cluster endpoint

The purpose of doing this is to remove any IP specific URL and use ELB specific URL.

Any advice? thanks.

Hi @weibin.wu

All [anything].[ip] does is to resolve via DNS to [ip] . It's just intended to act as a stop gap before you have DNS set up yourself, eg for getting up and running quickly

Now you have elb_dns, you should set up your in DNS provider (eg route 53) for *.elb_dns to resolve to elb_dns, and then change the "Cluster endpoints" (under platform > settings in the UI) to be just elb_dns

Then each cluster endpoint will be [cluster_id].[elb_dns] which will resolve (via your DNS provider) to the IP of elb_dns, which will route to the proxy and thence (via the [cluster_id] prefix) to the cluster itself

Does that make sense? Let us know if you run into issues



Sorry I just reread, and noticed:

I created an elb in front of my ECE cluster. So I can use url to access like this.
http:// [ELB_DNS] :12400/#/region/ece-region/allocators

Note that there are two different uses for an ELB -

  • to hit the admin API/UI on 12400
  • to hit the clusters via the proxy on 80/443/9200/9243

These are two completely different functions. The same ELB can do both via the port, eg 12400 should go to any IPs that run an adminconsole service, and 80/443/9200/9243 etc should go to any IPs that run a proxy service

Obviously if you have hosts that always run both proxies and adminconsoles, then it's an academic distinction, but I did want to be clear that it exists :slight_smile:

The above information on setting up your DNS provider to be able to hit the proxy is all still valid.

Okay, cool. Thanks for the tips. Worked with our SA and problem solve. Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.