How do I set number of replica to zero in metricbeat?

I have only 1 node cluster and hence I need only 1 shard and 0 replica for all my indices. I cannot set the number of replica to 0 for metricbeat index. My yml file looks like this: "metricbeat"
    setup.template.pattern: "metricbeat-*"
    setup.template.overwrite: true
    setup.template.enabled: false
      index.number_of_shards: 1
      index.number_of_replicas: 0
      index.codec: best_compression

What am I missing?

Sorry forgot to mention this is for version 7.10


Does it give you an error message or does it just not work?

As setup.template.enabled is false the template will not be loaded automatically - did you load the template manually?

Best regards

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.