How do i set total fields limit to be 2000 by default

Hi. Got a Q on this.. I would like to have a template so whenever a new Twitter index gets created the ES system makes total fields limit to be 2000 by default.
Bit like below...
Anybody knows how to modify the below to have this setting included?

curl -XPUT localhost:9200/_template/twothousandfieldslimit -d '
"order" : 1,
"template" : "twitter*",
"settings" : {
"index" : {
"mapping.total_fields.limit" : "2000"

What's wrong with this API call?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.