How do I undo a decommission of an IP?


(Martin Stabenfeldt) #1

Hi,

I've decommissioned a node by it's IP.

curl -XPUT localhost:9200/_cluster/settings -d '{
"transient" : {
"cluster.routing.allocation.exclude._ip" : "10.0.0.1"
}
}'

How can I remove that setting?
I tried the same command but as a DELETE request. Didn't work. :frowning:

Cheers,
Martin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/52a5b623-012b-466f-827b-ebcd8358b095%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Could you try if this is working?

curl -XPUT localhost:9200/_cluster/settings -d '{
"transient" : {
"cluster.routing.allocation.exclude._ip" : ""
}
}'

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 30 janvier 2014 at 15:44:18, Martin Stabenfeldt (martin@stabenfeldt.net) a écrit:

Hi,

I've decommissioned a node by it's IP.

curl -XPUT localhost:9200/_cluster/settings -d '{
"transient" : {
"cluster.routing.allocation.exclude._ip" : "10.0.0.1"
}
}'
How can I remove that setting?
I tried the same command but as a DELETE request. Didn't work. :frowning:

Cheers,
Martin

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/52a5b623-012b-466f-827b-ebcd8358b095%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52ea71f8.7fdcc233.45fa%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(Martin Stabenfeldt) #3

It worked, thanks! :slight_smile:

On Thu, Jan 30, 2014 at 4:38 PM, David Pilato david@pilato.fr wrote:

Could you try if this is working?

curl -XPUT localhost:9200/_cluster/settings -d '{
"transient" : {
"cluster.routing.allocation.exclude._ip" : ""
}
}'

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 30 janvier 2014 at 15:44:18, Martin Stabenfeldt (martin@stabenfeldt.net)
a écrit:

Hi,

I've decommissioned a node by it's IP.

curl -XPUT localhost:9200/_cluster/settings -d '{

"transient" : {

    "cluster.routing.allocation.exclude._ip" : "10.0.0.1"

}

}'

How can I remove that setting?
I tried the same command but as a DELETE request. Didn't work. :frowning:

Cheers,
Martin

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/52a5b623-012b-466f-827b-ebcd8358b095%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/MYfs_r9QiKE/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.52ea71f8.7fdcc233.45fa%40MacBook-Air-de-David.local
.

For more options, visit https://groups.google.com/groups/opt_out.

--
Martin Stabenfeldt
Tlf: +47 93441707

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAPVOyGnNq0F5DnrJ2p0xxDD60EKj7Pj%2BD3KY%2B7n5zyzVUhdP9g%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4

Undo decommissioning of a node